The Basics

Our home has a DSL line coming in to a modem on the second floor. A line then goes down to a switch/hub and through to our downstairs living room where a wireless router is set up. Up until last week, we received reliable 3Mbps Internet in this fashion to our devices (mostly iOS devices).

We also have DirecTV's whole-home DVR, which as I understand it means they linked all the DirecTV boxes together with Ethernet and also connected one DirecTV box to the wireless router.

The Events

The issue began when we added a new MacBook Air to the mix, which could not connect to the Internet. When everyone else had IP addresses in the 173.191.X.X range, this MBA kept giving itself a 166.X.X.X address and reported itself as "able to connect to the Internet" when it surely could not. Even giving it a static IP would not work. We had to renew the DHCP license until it randomly flipped to a 173.191.X.X IP address.

At the same time, we tried to upgrade our modem since it's about 7+ years old. To our great misfortune, the new modem seemed unable to get a PPP connection from the ISP. We switched back to the old modem, and now it seems like a free-for-all with our devices.

How My MacBook Pro reacts

My MBP, when I turn off/on wifi, will sometimes land me with a 192.168.X.X IP address, which I believe is a NAT-like 'local' IP address. My MBP will show me the router's IP and with that information I can connect to the web interface of my modem (Paradyne). I can look at the settings for a little bit, but eventually (30 seconds) I am forcibly redirected to my router's (Netgear) web interface. I can make changes here as well.

Whether or not I have Internet connectivity at this point seems random. If I renew my DHCP lease, it will give me another 192.168.X.X IP address for one second, at which time it disappears and I am given a 173.191.X.X IP address and Internet access (yay). This is the only device which can reliably get an Internet connection. My MacBook has been unable to connect through a wired connection to the modem or the router during this whole time.

How all the other devices react

None of the other devices can reliably connect to the network. If any of the devices receive the 192.168.X.X IP address, they cannot connect at all. If they receive the 173.191.X.X IP address, they can connect - problem is that has happened only twice, once through static addressing and once on a random DHCP lease renewal. On top of this, some of the devices are experiencing the same issue as the MacBook Air - they're getting a third type of IP address of 166.X.X.X. None of the devices we're working with besides my MacBook Pro have an Ethernet port, so I don't know if a wired connection works for them.

The Kicker and my specific question

The funny part is that I unplugged the line from the modem to the router and my MacBook still connects. It even shows on the router that it is receiving no Internet connection. This makes me believe there's a direct line from modem to router via the DirecTV installation.

I have tried completely restarting from scratch with the modem and cycling power on the router. The router is about 4 years old.

What I want is for all the devices to recognize the 173.191.X.X IP address as the way to go, but I know this is strange because I can only access the web interfaces for my router and modem using 192.168.X.X.

Do I have multiple DHCP servers working against each other here? Is there a possible direct line from the router to the modem made by the DirecTV box links? How can I tell where these devices are receiving their IP addresses?

UPDATE, May 18 2014 I ran the 'ipconfig getpacket' on my MBP (with option en1 for wireless) and on the MBA (with option en0 for wireless, not sure why it's different) and got surprising information:

MacBook Pro (always connects)
yiaddr = 173.191.X.X //machine address
giaddr = //gateway address
server_identifier (ip): //DHCP server address
subnet_mask (ip):
router (ip_mult): {} // router address
domain_name_server (ip_mult): {207.91.X.X, 166.102.X.X}
domain_name (string): [companyA].net

MacBook Air (never connects)
yiaddr = 166.82.X.X
giaddr =
server_identifier (ip):
subnet_mask (ip):
router (ip_mult): {}
domain_name_server (ip_mult): {207.91.X.X, 166.102.X.X}
domain_name (string): [companyA].net

So somehow the MBA knows who to connect to (domain_name) and has an ip address deriving from the gateway address. They both have the same DHCP server address, different subnet masks, different routers... What is the cause of this difference?

Update, May 21 2014

We now have Internet! I will post a solution when I figure out exactly what happened. We ended up removing everything and starting over outside where we first get the DSL line. we connected that to the modem, then directly to the router, and connected all machines with wifi successfully. Then step by step we added complexity in the form of walls and more wiring.
Right now it seems like the problem may have come from the "filter" the ISP put on our DSL line or from our hub/switch. I'll update again later.

  • You could tell where the devices are receiving the IP addresses from by doing a tcpdump on the macbook and see which MAC address responds to the DHCP request and gives it an IP address. – Lawrence May 16 '14 at 5:01
  • I'm getting a lot of information returned here on the tcpdump - how can I tell what the DHCP request/response is? – amess May 19 '14 at 0:37
  • Pastebin the tcpdump and we'll see if we can tell what's what. – Lawrence May 19 '14 at 2:34

I would expect 5 ethernet sockets on your router, one is the uplink, the other i'll call subnet ports. Four will be grouped or distinct from one other

Connect the modem directly to the uplink port on your router so the router gets the 173 address on the internet (be sure to remove that hub/switch between them that is causing the weird problem because every device races for the single external ip)

The mediabox should connect to a subnet port on the router. And the wifi base station too. The router can be the DHCP server, but the wifi base station too, and that could be the source of flapping problems. You would have the 192.168 subnet managed by the router on the wired/ethernet and let the wifi run on the 172.16 range. But if you can manage the ranges op the dhcp address pool then you can still create one subnet in 192.168.

Connect the uplink port of the hub/switch to one of the subnet ports of the router only if you need to wire more devices. The mediabox could be a bridge and i would not expect al lot of config options.

  • By my understanding, in this situation, I have the modem connecting to the hub/switch which connects to a wireless router - not a router AND wifi base station. Maybe I'm misunderstanding you, though. Regardless, I'll try directly linking the router and modem! – amess May 19 '14 at 1:44
  • Modem-cable-router. The router should exclusively connect to the modem. The rest can connect to the LAN ports on the router. – bbaassssiiee May 19 '14 at 21:56

UPDATE: Sorry this took me so long to get back to.

Apparently Our problem was with our ISP and with our modem. The ISP was not giving us the speeds we asked for.
On top of that (and the actual answer to the problem) was that, as @datasmid suggested, we had too much complexity and ended with multiple DHCP servers. The switch/hub was giving out ip addresses, as was our router. Simplifying the problem by starting from the very beginning (literally outside, connecting the ISP link to our modem and that to our router), we got a connection for all devices.

To all those who will come here later: Simplify the problem. We took away the switch/hub, disconnected our DirecTV from the connection, and made sure we could see every wire. That helped us figure out that the modem our ISP sent us was not working.
We then got bunch of 192.x.x.x connections as we should have. The other issues of my MacBook Pro connection and others not all came from these central issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.