0

I use Firefox as default browser on my Mac. For some reason I can't play Youtube videos anymore. Facebook videos work, and Youtube videos play fine in Safari. If I restart with all addons disabled, it works again. Then if I enable addons one by one, it works up til a certain moment. Then I disable the last addon again, but no luck. Then I disable all addons manually, and still no luck.

What happens is I see a black screen with "static". See the image:

Youtube Static

So I'm a bit lost here. What is the best way to solve this? How can I get this working again? Below the list of the addons I have installed.

  • Adblock Plus
  • Better privacy
  • Calomel SSL Validation
  • Date Picker / Calendar
  • DNS cache
  • Downthemall
  • Empty cache button
  • Flash and video download
  • HTTP fox
  • HTTPS Everywhere
  • Lucifox
  • Mailvelope
  • Master Password +
  • PWgen
  • QR Code image generator
  • Quickfox notes
  • Quick passwords
  • Saved password editor
  • Soundcloud Downloader
  • Tab mix plus
  • 1
    When you enable them one by one, which one causes YouTube to not work anymore? – user304064 May 16 '14 at 18:23
  • I have never used OS X, but I think you should try disabling all of those add-ons (then see if you can watch You-Tube, from there,re-enable each one until You-Tube no longer functions, I think you should be able to figure out from that if that is the issue or not. – L.B. May 16 '14 at 18:39
  • @SPRBRN I do have one question for you though, were there any error codes or messages that popped up and mentioned a problem? – L.B. May 16 '14 at 18:40
  • I've added an image of what happens when I open a Youtube video. I know the principle of enabling the addons one by one. The problem is that this method doesn't work. Say I do this alphabetically, then up til a certain addon, it works, then it stop working. So you think that this last addon is the problem. I disable that addon, but no, it doesn't work. Then I disable the previous, no change. Then I disable all manually, but not via the safe restart, no change, no video. – SPRBRN May 16 '14 at 19:01
1

I had this problem for a long time, and I figured it out the hard way.

I encountered this problem whenever I'm on youtube with SSL enabled, and there was no issue while using an http only connection. And it seems flash plugin will establish a connection on its own to stream the videos. The flash client always throws an error when some special cipher suites used in the browser SSL configuration are disabled (RC4/SHA, RC4/MD5) in your browser. The RC4 cipher suites are weak and some add-ons disable them by default for security reasons.

From your add-ons list you have HTTPS everywhere (which would default to https youtube) and Calomel SSL validation (which can disable RC4 cipher suites). It is no fault of the add-ons that video breaks, and it is good to disable RC4. What I'm not sure is to put the blame on a crappy flash client or a youtube stream server that cannot handle modern cipher suites.

In short : go to about:config, search for security.ssl3. and find out the entries for rsa_rc4_128_sha/rsa_rc4_128_md5 and set them to true. Reload youtube, and you are good to go. Most likely Calomel will reset those after a restart. But I think there are options to allow all cipher suites in calomel preferences.

EDIT : The reason you saw the problem even after disabling the add-ons is that calomel might not reset the cipher suite settings after removing.

| improve this answer | |
  • Disabling HTTPS Everywhere for Youtube does the trick. Not how I would like it, but it's good to know this solution! Thanks! – SPRBRN Jun 23 '14 at 18:21
0

Under Firefox: Complements->Plugins->Shockwave Flash, you need deactivate or uncheck the option "Activate Protect Mode Adobe Flash". Then restart Firefox. You can play YouTube videos again.

| improve this answer | |
  • 1
    OP said If I restart with all addons disabled, it works again. which means there is no problem with plugins, its an addon which is causing problem – pun Nov 6 '15 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.