Not long before, I executed dd on my USB drive, but later when I needed it. I found it could not be formatted in Windows Disk Management, which said "The system cannot find the file specified." So I had my USB drive formatted on Linux.

now issue occur. Windows 8.1 does not assign a drive letter, making it unable to be accessed in Windows Explorer, and though it is shown in WDM, any operation returned message mentioned above. But there is no problem when on Linux on my machine and on Windows on another machine.

  • How did you format it? What happens if you format it with an MBR and a FAT32 partition?
    – Mario
    May 17, 2014 at 9:20
  • @Mario I used dd to zerofill MBR, cfdisk to create a partition, and mkfs.vfat to create filesystem. Nothing wrong happened. I copied some files into USB driver, and they could be read on another Windows machine.
    – Noverull
    May 17, 2014 at 9:51
  • So another Windows PC is able to read it, just not your own?
    – Mario
    May 17, 2014 at 9:52
  • @Mario Not exactly. Linux is able to, but Windows is not.
    – Noverull
    May 17, 2014 at 9:54
  • Asking due to this: and they could be read on another Windows machine.
    – Mario
    May 17, 2014 at 10:17

5 Answers 5


As we found out through the comments the problem may be solved using Windows' diskpart. Obviously the Linux tools somehow created a MBR and/or partition table Windows couldn't read properly (or had some other issue with).

If you're using these instructions, do so with care! Making mistakes might mean you're losing all data on one more more disks. If you're unsure, let someone else who's more experienced do this!

  • Open the start menu and type diskpart. You should get one hit, launch it and confirm the UAC prompt in case you're asked.

  • Wait for the console window to show an input cursor (flashing horizontal line behind DISKPART>).

  • Type list disk and confirm with Return.

  • Locate the disk you'd like to format/reset. Double check you pick the right one. Remember its number (listed under ###) for the next step.

  • Now type select disk # where # is replaced with the number from the last step.

  • Once again type list disk and the correct disk should be marked with a * in front of it.

  • Type clean, confirm if asked and wait for the operation to finish.

  • Leave diskpart using exit.

  • Windows Explorer should now ask you what to do with the uninitialized/empty disk. If it doesn't, have a look at disk management (open the start menu and run diskmgmt.msc). You should find the uninitialized drive and be able to create new partitions and format them.

  • 1
    This doesn't help in my case. After cleaning, it hasn't showed up in My Computer. The disk management utility created a volume, but failed to format it ("The system cannot find the file specified", again...). Same with diskpart. I've also tried to recreate the MBR table with fdisk, but even this was not helpful. Oct 24, 2014 at 8:40
  • Edited to add additional instruction from Vladislav Kuzmin below May 9, 2016 at 9:44

I had exactly the same issue and the Mario's solution did not fix my problem. Additionally to Mario's solution do the following:

  • after 'clean' do not leave diskpart using 'exit'
  • type 'create partition primary'

This will create primary FAT32 partition (which was not possible from the Disk Manager as described in comment of 'Stanislav Mamontov' to Mario solution). This partition will be recognized, directly mounted and available. Now you can reformat to e.g NTFS if needed.

  • You saved my pendrive. Thanks a lot. It was not being detected on only win 10 after using hp usb format tool. The create primary partition really helped. :)
    – Ashu
    Aug 23, 2016 at 14:47

Similar issue, Verbatim Store 'n Go, couldn't do anything with it on Windows 10. Windows 7 was able to access it fine. Formatting on the Windows 7 machine did not help. The Disk Management tool in the Computer Management app kept throwing errors (when trying to assign a drive letter it kept throwing a "Cannot find file specified" error). Deleting partitions there and recreating didn't help.

For me Mario's Diskpart Solution kept throwing an error "Access is Denied", with the following in event log: 5@0101000F - Cannot zero sectors on disk \?\PhysicalDrive1. Error code: \?\PhysicalDrive1

Trying a "create primary partition" after "clean" did not work either.

Tried Paragon to wipe the disk and recreate the partition, this "succeeded" but the original problem persisted.

What did work was SD Memory Card Formatter

Perhaps some of these newer USB drives are just SD cards with an adapter? In any case, it's worth it to try SD Memory Card Formatter.


In my case, the create primary partition command did not help. Disk Management still failed with "The system cannot find the file specified".

What ultimately solved the problem was this: instead of using the clean command in DISKPART utility, I used clean all. This command writes zeroes in every sector of the disk, effectively creating a true unpartitioned space. It takes some time, but it works.

Afterwards you can create a new partition, format and allocate the letter in Disk Management.

The solution is equivalent to using Easeus partition manager mentioned above, but you can do it without installing any 3rd-party tool. So the key is really to wipe the USB stick clean before creating a new partition.


If using DISKPART to clean the disk and remake the partition doesn't work, look at some of the answers on Recovering a Partially Formatted USB Thumb Drive. I found that after doing all of Mark Tomlin's answer, I had to repeat it but converting to GPT instead of MBR. That worked. I then converted back to MBR (which had a few problems that I solved as explained on the other post).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.