1

In MS-Word 2013, I set display settings in Options ->Advanced - > Display so Numerals are displayed according to context. My doc is RTL document and in that context numerals should be displayed in Hindi style. I also have some text in the document in English and of course they should be displayed in Arabic style.

The problem is, some of my captions numbers are displayed in Arabic style no matter what I do to them.

Any idea how to set the context for them so Word will display them appropriately?

  • 1
    Are these definitely numbers generated from fields, not, e.g. automatically generated paragraph numbers? If so, I wonder if the following will work. Go to File->Options (or the Word 2013 equivalent), then Quick Access Toolbar. Under "Choose commands from", select "COmmands not in the Ribbon". Find and select "Ltr Run" in the list and click Add to add it to the QAT. Then do the same for "Rtl Run". Then select the field in the RTL text and click the Rtl Run button. – user181946 May 20 '14 at 7:58
  • @bibadia Sorry about the delay. It took time for me to get the problem again. Your solution works. Please provide an answer so I can mark it as an answer. – Mehraban Jun 3 '14 at 10:37
1

For numbers generated from fields, not, e.g. automatically generated paragraph numbers, the solution appears to be to select the field and use the Word Command "Rtl Run" or "Ltr Run" to set the direction of the "text run"

You can put those two commands in the Quick Access Toolbar (QAT), e.g. as follows

  • Go to File->Options (or the Word 2013 equivalent), then Quick Access Toolbar
  • Under "Choose commands from", select "Commands not in the Ribbon"
  • Find and select "Ltr Run" in the list and click Add to add it to the QAT
  • Find and select "Rtl Run" in the list and click Add to add it to the QAT

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.