14

When I hover my mouse cursor over a running application's button in the taskbar, small windows appear showing the contents of the open program. How can I disable that? I find it quite annoying.

taskbar thumbnail preview

1
  • AKA Windows Peek, I love this feature in Vista+... But I am also surprised there are no questions for this yet. May 17, 2014 at 17:53

5 Answers 5

-2

In Windows 8 or Windows 8.1 hit the Win+W keys (for search) and type in visual effects hit Enter and in the Performance Options window uncheck the option Animations in the Taskbar. I think this will do the trick.

animations in the taskbar

8
  • Please +1 and check as answer :)
    – Devid
    May 17, 2014 at 18:09
  • 8
    Does not work on Windows 8.1
    – Chris
    Jul 21, 2014 at 13:23
  • @Chris why is it not working ? It should work for Windows 8.1. Are you sure, 100% sure that it is not working ?
    – Devid
    Jul 21, 2014 at 17:53
  • 2
    @Devid i.stack.imgur.com/aeQE2.png
    – Chris
    Jul 22, 2014 at 6:26
  • 5
    This doesnt work for me either. Windows 8.1 Oct 31, 2014 at 13:39
19

On Windows 8.1 you can get rid of it with these settings:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Taskband]
"NumThumbnails"=dword:00000000

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"ExtendedUIHoverTime"=dword:41fffffe

Import them and restart Explorer. See here.

7
  • Awesome, I was about to answer this, and then it turns out my answer is already linked here :)
    – Zook
    Aug 30, 2014 at 18:25
  • this solution worked for me. Oct 31, 2014 at 13:45
  • 2
    I don't see the point of the NumThumbnails entry when the underlying mechanism here is just ExtendedUIHoverTime making it take a very long time to show up. Nov 16, 2014 at 1:44
  • Indeed, you don't need NumThumbnails. Other than that, this is how you fix it on Windows 8.1. Jan 20, 2015 at 11:25
  • 1
    This worked on Windows 10. Sep 15, 2016 at 23:28
6

A few options (I've only tested option 4):

Option 1: (I haven't tested this one)

  1. Click on Start button and type RegEdit in Instant Search text box, then hit Enter.

  2. In the Registry Editor, navigate to the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    Note: If Explorer registry sub-key does not exist, then right click on Policies and click New -> Key and name it as “Explorer”.

  3. In the right pane, right click and select New -> DWORD (32-bit) Value.

  4. Type TaskbarNoThumbnail as the name for the new registry value data.

  5. Double click on TaskbarNoThumbnail to modify its value data.

  6. Type 1 and click on OK.

  7. Restart computer if needed.

    To re-enable Taskbar thumbnails again, just right click on TaskbarNoThumbnail and click Delete to remove the whole registry key, or set TaskbarNoThumbnail value data to 0.

Option 2 and 3:

Install 7+ Taskbar Tweaker 4.5 - This does work on Win 8.1

In the Hovering section, check the box 'nothing'

Install Taskbar Thumbnails Tuner - According to one person who commented on this page (jonesy), it works in Windows 8.1, but I haven't tested.

At the bottom, check the 'Disable thumbnails' box

Option 4: (I've tested this one)

  1. Open Control Panel > System (in icons view)
  2. Click Advanced System Settings on the left
  3. Alternatively, you can just search for (win+w) visual effects
  4. Go to the Advanced tab
  5. Click Settings in the Performance area (the top area)
  6. Check the Custom box
  7. Uncheck the 3rd checkbox - "Animations in the taskbar"
7
  • 2
    Is this tested and working in Windows 8 ? Because I think the second option does not work in Windows 8.1.
    – Devid
    May 17, 2014 at 17:52
  • The first option is copy-pasted from here without proper credit. Besides, it only works in Windows Vista.
    – and31415
    May 17, 2014 at 18:01
  • 1
    In 8.1, "Animations in the taskbar" doesn't have anything to do with the hover thumbnails.
    – user326745
    May 26, 2014 at 14:02
  • 3
    No it doesn't. Thumbnails still happen with that unchecked. It probably controls the fade-in of the thumbnails, I bet they just appear with no fade if you uncheck it.
    – Zook
    Aug 30, 2014 at 18:27
  • 1
    Option #3 DOES work in Windows 8.1 when nothing else listed on this page worked. Jun 18, 2015 at 15:48
2

Do what it shows in the first example, but instead of unchecking "Animations in the Taskbar"; uncheck "Enable Peek" instead.

2
  • This worked for me on Windows 8.1. Unchecking "Animations in the taskbar" did not. Nov 30, 2014 at 0:05
  • 1
    This will get rid of the desktop preview, but not the popups when you're over a task button. Jan 20, 2015 at 11:04
2

This works for me in Windows 8.1

http://winaero.com/download.php?view.27

Nothing else suggested worked enter image description here

1
  • Including the name and a description of the tool in your answer would be useful if, in the future, the link no longer works, which unfortunately does happen.
    – miyalys
    Oct 4, 2015 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.