1

I have a old WD Black drive that is not Advanced Format. Due to it having one bad sector in a unused area I need to clone it to a new hard drive to avoid losing data. Unfortunately the same model of drive is not for sale anymore. I bought a WD1003FZEX Black 1TB which has Advanced Format. When I try and clone the old non-AF hard drive to the new Advanced Format drive Clonezilla complains that the new drive is too small by a few sectors.

Some facts.

  • Old drive is formatted as a Windows 7 NTFS drive. Has 100mb "System Reversed" partition.
  • Old drive is 512 sector size
  • New drive is Advanced Format
  • I am cloning to the new drive using a external USB enclosure.
  • My guess (without doing any research) is that the new drive is using a larger sector size (that's what "Advanced Format" is) and this is confusing CloneZilla. Is it possible to reformat the new drive using 512-byte sectors? That might fix the issue. (If you have a 3TB+ drive, this won't work, but I imagine it would be fine for 1TB.) – user55325 May 19 '14 at 4:04
  • try partedmagic. If it says the destination is too small you can resize the original partition down by say 10mb(or whatever) problem solved. – cybernard May 19 '14 at 4:06
0

Try using dd_rescue (called ddrescue in ubuntu variants) and piping it into something like xz (or the more universal gzip and bzip2). This will insert zeros where the bad sector was but not break on the bad sector, and will compress the output so it will hopefully fit on your second hard disk.

Example:
dd_rescue /dev/sdX - | bzip2 > /mnt/working_external_disk/diskimage.img.bz2
where sdX is the block device of the faulty hard disk, and the - symbol directs output to stdout, where it is piped to bzip2, and bzip2 outputs the compressed disk image to /mnt/working_external_disk/diskimage.img.bz2. You should then be able to decompress it when you have a bit more space, and mount it with mount -o loop /path/to/decompressed/disk/image.img /path/to/mount/to.

If you don't want to make the investment in a slightly larger drive, you can always try to use split to split a few sectors off the disk image. It probably will not mount properly afterwards, but it is worth a shot.

Sorry if this doesn't answer your question, but I am currently backing up a huge amount of data and am in a similar predicament, and this is what eventually worked for me. I had to get a bigger drive but I was able to make a copy of the bad disk in the meantime with bzip2.

If you aren't using linux/unix, sorry for wasting your time, but I have little experience with windows when it comes to backing up disks.

  • I use Linux but this hard drive is NTFs. – jtl999 May 19 '14 at 2:18
  • Sorry for the late reply - This should still work. Just be sure that you unmount the drive first and run everything with read-only access. – Wyatt8740 Jun 9 '14 at 1:41
  • I've already done a fresh install of Windows on the new drive and I'm not sure my old failing drive works anymore. Hopefully your advice helps the next person who has this problem. – jtl999 Jun 9 '14 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.