0

I run a single user instance of Atlassian Confluence and yesterday I upgraded to version 5.5. My Confluence wiki worked fine after the upgrade. However, after a reboot when I tried to access my wiki using its usual URL I received this error:

This page can’t be displayed

• Make sure the web address http://localhost:8090 is correct. 

• Look for the page with your search engine. 

• Refresh the page in a few minutes.

I checked to see if the Atlassian Confluence service had started, and it has not, so I tried to do that manually. I received this more helpful error message:

Windows could not start the Atlassian Confluence service on Local Computer.

Error 2: The system cannot find the file specified.

My sys admin skills are few but I uncovered https://confluence.atlassian.com/display/DOC/Setting+the+JAVA_HOME+Variable+in+Windows which led me to try changing the JAVA_HOME system environment variable from C:\Program Files (x86)\Java\jdk1.6.0_35 to C:\Progra~2\Java\jdk1.6.0_35 but this did not help (even after a reboot).

I am reasonably sure that a Java upgrade I accepted recently may be involved in this error. I am using Windows 7 SP1 and have these subfolders present in C:\Program Files (x86)\Java:

  • jdk1.6.0_35
  • jre7

Can anyone advise on whether they know a solution for how to restore my Atlassian Confluence 5.5 to a working condition?

2

It's a bug introduced in v5.5 - see CONF-33492.

The linked issue includes a simple registry hack workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.