0

I did a clean install of Win 8.1 Pro along with several other development tools. I could get a list if needed, but somewhere early on, I installed Office 2013 Home and Student...and I installed VS 2013 after that at some point. I didn't check things as I was going, but when I am now finished. *.xml files are showing (and opening with) notepad icon. On my old machine (admittedly, a Win 7 machine) it has the proper 'xml document icon' and if you open it, it opens in a browser by default.

(embarrassed) I think I recall chasing this problem down before 4 years ago and solving it, but I can't find any documentation and I'm not finding the solution again on the web. So I thought I'd ask here, so it would be 'documented' in SO if someone is able to help.

So does anyone know how to fix my *.xml files so they are associated with proper settings? (note I did export my HKCR/xmlfile registry key from my Win7 (working) machine and applied it to the new Win8.1 machine, but it still didn't fix it :(

Thanks in advance.

3
  • Why don't you just right click and open with the program of your choice and set the default application to open xml with.
    – Devid
    May 19, 2014 at 19:45
  • Terry, if you feel like any answer or comment helped you solve your problem, you should upvote it. Jul 29, 2014 at 16:18
  • I haven't been able to resolve it yet. I didn't try NirSoft's program as I know I resolved this before on my Windows 7 install a couple years ago. Frustrating that I can't remember, but holding out trying to figure out.
    – Terry
    Aug 1, 2014 at 23:57

3 Answers 3

0

As suggested here on SuperUser try removing (and hopefully backupping before) the IconHandler sub-key from xmlfile key.

2
  • 1
    In addition to this, I changed the (default) value for Shell/open to "C:\Program Files\Internet Explorer\iexplore.exe" %1
    – Terry
    Jun 26, 2015 at 14:58
  • cool. I did that as well now
    – superjos
    Jun 29, 2015 at 8:18
1

I'm not sure if that is too easy, but you can set this under Settings > Search and Apps > Default

(Source: http://windows.microsoft.com/en-us/windows-8/choose-programs-windows-uses-default)

edit: Maybe this topic is also of interest for you: How to recover my .xml default icon?

0

I don't know what broke it, but you can see and repair the association with NirSoft's FileTypesMan.

1
  • Will try this if no other suggestions...hoping not to have to install a third party application to pull this off. I'm hoping for a registry fix. Will let you know.
    – Terry
    Jun 3, 2014 at 4:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.