1

my Ethernet connection somehow stopped being detected by Windows and Ubuntu on my laptop(Dell Inspiron M5010) all of a sudden after just another reboot. The local area connection is not showing up in network connections. Due to this I'm not able to connect to my broadband internet connection. I've tried updating drivers, checking device managers and stuff, but it's just not there! As if my network card is absent! I have no idea how to fix it, if it can be fixed at home somehow, it'll be absolutely great. It's not a problem if I need to open up the laptop for whatever reason. Please ask if there is some additional info I need to provide. Thanks in advance.

  • In linux, does either the lspci or dmidecode -t baseboard commands list the device? – Thebluefish May 19 '14 at 22:00
0

Although your question was asked over a year ago, I thought I'd post the resolution that worked for me while it was still fresh in my mind.

My situation was that I had upgraded a Dell Inspiron N5010 from Windows 7 Home Premium (SP1, x64) to Windows 10 Home and noticed after doing so that the NIC was not showing up in Device Manager. Now, I'm not sure if I had installed the NIC driver prior to upgrading to Windows 10. In fact, based on the drivers I downloaded/needed from Dell when I did the clean Windows 7 install, I very well may NOT have installed the NIC driver prior to the upgrade. I was using WiFi for network connectivity and Device Manager did not show the NIC with an exclamation point in Device Manager while doing the Windows 7 clean install (so I did not see the need for it at that time).

Whatever the case, I verified it was 'Enabled' in BIOS which it was. I then downloaded the Windows 7 x64 driver from Dell and installed it but got an error message while doing so that it couldn't find some file. That install did seem to complete normally once I clicked 'OK' but there was still no NIC in Device Manager, even after a reboot.

What did it for me was I downloaded the Windows 8/8.1 NIC driver from Realtek (the RTL8103T in my case) and installed that. During the install (a 'Repair' install as it automatically detected that there was a driver already installed), a message popped up stating that it couldn't detect the NIC and that I should plug in an Ethernet cable because the NIC could be in a 'Deep Sleep' state. I plugged in an Ethernet cable, waited for a few seconds and when the message window didn't go away automatically, I clicked 'OK'. The installation completed successfully and the NIC was then listed in Device Manager, even without a reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.