3

i'm currently using OpenWrt Backfire 10.03 on an Asus WL-500G Premium v1. Scenario is like that: AP should connect to a RADIUS server via wired ethernet and perform authentication requests.

I'm running into problems when i try to apply the new configuration file. output of /etc/config/wireless (obv. not production mode)

config 'wifi-device' 'radio0'
        option 'type' 'mac80211'
        option 'channel' '5'
        option 'macaddr' '00:1f:c6:51:34:dc'
        option 'hwmode' '11g'
        option 'disabled' '0'

config 'wifi-iface'
        option 'device' 'radio0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'OpenWrt'
        option 'encryption' 'wpa2'
        #RADIUS Server
        option 'auth_server' '192.168.1.249'
        option 'auth_secret' 'test123'
        option 'acct_server' '192.168.1.249'
        option 'acct_secret' 'test123'

performing uci show wireless sets the configuration parameters as expected

wireless.radio0=wifi-device
wireless.radio0.type=mac80211
wireless.radio0.channel=5
wireless.radio0.macaddr=00:1f:c6:51:34:dc
wireless.radio0.hwmode=11g
wireless.radio0.disabled=0
wireless.@wifi-iface[0]=wifi-iface
wireless.@wifi-iface[0].device=radio0
wireless.@wifi-iface[0].network=lan
wireless.@wifi-iface[0].mode=ap
wireless.@wifi-iface[0].ssid=OpenWrt
wireless.@wifi-iface[0].encryption=wpa2
wireless.@wifi-iface[0].auth_server=192.168.1.249
wireless.@wifi-iface[0].auth_secret=test123
wireless.@wifi-iface[0].acct_server=192.168.1.249
wireless.@wifi-iface[0].acct_secret=test123

But when i try to bring the wifi back up errors are thrown

root@OpenWrt:/etc/config# wifi down && sleep 5 && wifi
Configuration file: /var/run/hostapd-phy0.conf
Line 46: unknown configuration item 'auth_server_addr'
Line 47: unknown configuration item 'auth_server_port'
Line 48: unknown configuration item 'auth_server_shared_secret'
Line 51: unknown configuration item 'radius_acct_interim_interval'
Invalid IEEE 802.1X configuration (no EAP authenticator configured).
5 errors found in configuration file '/var/run/hostapd-phy0.conf'
Failed to start hostapd for phy0

Why isn't the router using the /etc/config/wireless file? I tried to restart it with no success

2

I've managed it. The problem was that the wpad-mini package was installed but it does not support WPA2-Enterprise security. It was nescessary to perform
opkg update opkg remove wpad-mini opkg install wpad

Now everything is working as intended!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.