5

Thunderbird 24.5.0

I have two mail accounts that I have deprecated, one I do not have login information for anymore, the other I would like thunderbird to stop downloading emails from (as they are forwarded to a current email address).

I have not been able to find a way to perform this.

I have tried going to Synchronisation & Storage > Message Synchronizing > Advanced and unselecting every mailbox tickbox under download as I thought this would stop them downloading (this has not happened).

I cannot find any other settings that can do this.

The only approach I can think of is changing the account information on the mailbox so that it cannot connect but I think this will lead to thunderbird prompting for a password every time. The only other approach is deleting the account and moving the mail somewhere else for storage, but I prefer having it in one place for a universal interface should I need to search old emails.

Does anyone know of a way to stop thunderbird synchronizing an account, without unintended consequences such as prompting for passwords?

6
  • Never tried, but couldnt you use the local "folder" (database) system there to move the e-mails into a safe location, that would still be shown in the program, then remove the account entirely? Like after backing things up, or exporting so you don't lose anything in the process. – Psycogeek May 20 '14 at 13:54
  • @Psycogeek Thank you, that seems to be a decent solution. There seems to be one problem, trying to copy from the account that I no longer have access to doesn't seem to work (I assume it tries to synchronise with the server or something). I don't assume you have any advice for that do you? – Mike H-R May 20 '14 at 14:26
  • Its synced with imap but i can read the message fine in the mailbox, and it can't be downloading data as i no longer have security credentials for the mailserver. – Mike H-R May 20 '14 at 14:33
  • oh well, not sure why it wasn't working but I solved that issue by downloading an add-on copy folder which must've bypassed whatever the issue is. Do you want to write up the "copy to local folder then delete" thing as an answer as it solved my problem. :) – Mike H-R May 20 '14 at 14:36
  • Sounds like something that occurs because the whole of the e-mail is not downloaded from the server? (headers only) ? I dont know, are they trying to gather more info when opened? Is this POP type mail or one of the HTML type mails? It seems to work here, right click the e-mail select CopyTo and select the local folder? – Psycogeek May 20 '14 at 14:36
3

As pointed out by Psychogeek the only solution I found was copying to a local folder and deleting the mailbox.

I had an unusual issue with a mailbox that I no longer had access to (a pop-up opened every time I clicked on one of the folders within it asking me to check my password/say it couldn't connect), as I could not copy the messages from within the mailbox (not sure why). This was circumvented with the copy-folder add-on which worked fine.

P.S. I have no idea what was causing the problem.

2

It's too bad that there's no built in option for this, but I managed to find the following dirty solution which is good enough for me:

  1. Change the server name to 0.0.0.0. This way Thunderbird won't be able to connect to the server. I get no password prompts. I do see a message at the status bar that says that it's trying to connect to 0.0.0.0. Not perfect, but that's the best solution I could find.
  2. Uncheck automatic new message checks on startup and every 10 minutes. Saves the automatic connection attempts.

enter image description here

1
  • 2
    This is the answer that works for me, in December 2020 on Thunderbird 78.5 run as a portable app on Windows 10. Much appreciated. – Martin Zaske Dec 1 '20 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.