0

I have installed ushareand want to start is with booting. sudo service ushare startworks, and there is a link to start ushare in /etc/rc2.d (and also rc3, rc4, rc5) and there are stop links in other folders.

But after system start ps ax | grep ushare shows ushare is not running.

What could go wrong?

1

We should enable the service to start at run level. To check ushare is enabled as a service at runlevels

Check chkconfig --l ushare in command prompt.

ushare 0:off 1:off 2:on 3:on 4:on 5:on 6:off

If it is not set on then you need to set ushare to be started on boot.

chkconfig ushare on

Otherwise use update-rc.d command to enable or disable a service at a run level:

$update-rc.d ushare defaults

5
  • the output is as you posted, yet it still doesn't work – pirad May 21 '14 at 14:37
  • Check the updated answer – vimodhan May 22 '14 at 5:06
  • update-rc.d just tells me that the links already exist. – pirad May 24 '14 at 21:46
  • try once $sudo update-rc.d -f ushare remove and again $update-rc.d ushare defaults – vimodhan May 26 '14 at 6:23
  • Just tried it, still doesn't start up. I wonder if I should try starting ushare via cron. – pirad May 28 '14 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.