I just ran the Speakeasy Speed Test over a wireless connection and got these results:

  • Download Speed: 291 kbps (36.4 KB/sec transfer rate)
  • Upload Speed: 3662 kbps (457.8 KB/sec transfer rate)

Yes, they look inverted and yes, downloading is quite painful. I'm looking for suggestions on what is happening here.

The wireless was added onto the router over a year ago and it has been running perfect up until about 2 months ago. Then downloading starting becoming painful / impossible. I'm in a suburb neighborhood in a house and there aren't too many other networks around: right now only 4 others are showing up with the Mac and their signals are really weak; mine is full-on strong. Using Network Stumbler on the PC shows up to 9 other APs with SNRs about 10 dB lower than the one I'm on.


  • TRENDnet TEW-637AP / A (H/W:V1.0R)
  • Linksys BEFSR41 Cable /DSL Router
  • MacBook OS X 10.6.1 (Snow Leopard) -- connected via 802.11n
  • Dell Inspiron 2200 PC laptop -- connected via 802.11g

Today is the first time that the Mac and the PC have both been on the same network (I'm visiting the folks) and normally they just have the PC.

The Speed Test doesn't run from the PC.

From the MacBook:

  • RSSI: -55
  • Transmit Rate: 39 - 137 (values for the speed test above when the rate was 137; transmit was slightly lower at 39)
  • Channel 11, behaves similarly on other channels as well

I tried AP Grapher on the Mac but it's not compatible with Snow Leopard right now.

Thoughts? Ideas on what to try next?

  • 1
    Perhaps you connected the network cable the wrong way 'round? :o) Nov 26 '09 at 21:50

Run MTR (Matt's traceroute) in terminal on your Mac with your ISP's IP on and see if something is dropping packets like this: ~ user$ MTR xxx.xxx.xxx.xx

  • I'm working on getting a version of mtr on my machine but in the meantime a machine that is plugged into the wireless gets great up and download speeds.
    – dwj
    Nov 27 '09 at 2:34
  • Sadly, I did not add XCode to my machine before traveling this weekend.
    – dwj
    Nov 27 '09 at 2:59
  • Running mtr on a linux box on the wireless and it's getting some single digit percentage lost packets. However, the wired machine is seeing reasonable rates. It's something with the wireless.
    – dwj
    Nov 27 '09 at 3:36
  • Reboot everything. Swap in another wireless AP. Nov 27 '09 at 19:06

I fixed it by completely replacing the router and the wireless AP. Four hours of fighting with it was enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.