1

I have two keyboards, one used primarily for typing and the other for R&R. The latter is Razer Orbweaver, which is like a half of a normal keyboard with several other keys slapped in various positions. It's intended to be used with a special piece of software that lets you remap keys to your liking - available, unfortunately, only for Windows.

Now, in Linux I'd love to remap the Alt key on this auxiliary keyboard to Ctrl. Issuing the 'setxkbmap -device -option altwin:ctrl_alt_win' has the desired effect, however it applies to both keyboards, which leaves me without a good deal of shortcuts in Openbox.

Why doesn't the '-device' key work? Is there some sort of special condition to fulfill or does it only apply to layouts and won't work for my purpose under any circumstances?

Running OpenSUSE 13.1 with Openbox and trying to stay clear of KDE and Gnome if possible (not critical, but having a bunch of otherwise useless libs for the sake of a single option is undesirable).

Thanks in advance.

3

The parameters for setxkbmap seems to be wrong:

-device

needs a device ID specified. Such a device ID is a number which you could obtain by

xinput -list | grep -i key

A similar problem is discussed here:

Two keyboards on one computer. When I write with A I want a US keyboard layout, when I use B I want Swedish. Possible?

(BTW: you got my moral support in trying to use the Orbweaver with Linux, I will do the same very soon.)

  • Sorry it took so long to test and approve your answer. Health issues. Anyway, your suggestion was entirely correct; after providing the '-device' key the appropriate ID the issue was resolved. – XNRL Mar 16 '15 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.