Consider a netbook - Lenovo S10e with Windows 7 and the S10 Lenovo power management tools. Machine has factory BIOS.

Fn+F5 is the key combo to toggle the wireless radio on/off.

The tool allows the disabling fine; works as expected. The problem is that the re-enable doesn't work, or is confusing on how to re-enable.

Previously tried without success:

  • Fn-F5
  • Fn-Ctrl-F5
  • Fn-Shift-F5
  • Fn-Alt-F5

Here's the onscreen display:

alt text

Question: How can you re-enable the wireless radio using the Function key on a Lenovo netbook?


This just happened to me on my ideapad. Go to Network and Sharing Center in the Control Panel, then choose Change Adapter Settings. That's where you'll see your wireless card is diabled. Right click on it and enable. Obviously a little late for the the original poster but this is for everyone else who finds the page.


The problem OP described is the same one I was experiencing on a MUCH newer Lenovo Thinkpad model (Late 2012/Early 2013), so I'll leave this here in case others can benefit from it. There's a wireless network interface you can access through the Lenovo Thinkvantage Tools. I tinkered with the green "On" switch - flipped it to off - and couldnt' get it to go back to "On" mode.

I had to enter the BIOS setup menu on boot in order to reactivate.

  • On boot, press Enter or whatever your machine calls for to enter setup (this will be displayed on the first screen briefly on reboot so act quickly)
  • Navigate to "network" settings
  • Set Wireless adapter switch from off to on.

This seems to be a glitch with that toggle switch on some Lenovo models. Why this ThinkVantage Tools (and whatever they call it for IdeaPad) exists or how it helps me, I don't know. But this wireless toggle issue is only one of many that I've had with those "tools" and "control" panels Lenovo shipped with the PC.


The message seems to indicate that the master wireless switch is turned off. You don't mention this in your post. Unfortunately, I am not familiar with the exact model, but most of these machines have a physical wireless toggle switch on them - the software controls won't work if it's turned off.

  • 1
    I know it's an old post, but hey, somebody might need this...hehe. – Shinrai Jul 30 '10 at 15:29

[Solution to FN+F5 not working]

I faced the issue of WiFi not being enabled in May 2016 (suddenly FN+F5 stopped working and I could not reenable the WiFi on my Lenovo Y580) after many of the forum posts had been written. None of the proposed solutions I came across solved my problem. Now I found a solution and am here to share it: Go to Lenovo support page http://support.lenovo.com/br/en/ and select your laptop (mine was Ideapad Y series (ideapad) Y580 model bought back in 2012, great machine), select your operating system, mine is Windows 7 (64-bit) and download and install the BIOS update. I don't know why, but flashing (updating) the BIOS worked, once computer restarted FN+F5 worked again, as well as the "A" symbol on the screen when Caps Lock was pressed started appearing again as well.

Below I will list all the things I tried from forum and Lenovo pages to solve the problem that did not solve it (but may solve your problem in case updating the BIOS won't do):

  • Going on Control Panel/Network and Internet/Change adapter Settings and enabling the Intel wireless connection: Windows cannot enable it, it actually recommends you use a physical switch or use function keys when you use the "diagnosys" function.
  • Going on Win+R -> msconfig -> "Startup" and enabling all "Startup Item"s named "Lenovo ...". (Strangely, my "startup" list does not contain "Lenovo Utility" item as I have seen on the internet, not even now when all is working well.)
  • Going on BIOS (restarting computer and pressing F2 when Lenovo icon appears) and disabling the Wireless connection, then restarting, going on BIOS again and enabling the Wireless connection.
  • Uninstaling and installing again the other software for download at the support page for my laptop model, "Lenovo Onekey Recovery" and "Power Management", or installing the "HotFix" listed there.
  • Plugging my computer to a monitor, using "extended option" to extend desktop to both screens (laptop and monitor) and trying FN+F5 (I thought the dialog box was opening on a hidden area of the desktop as I sometimes use a monitor)

Now that was 2 hours finding the fix to this problem that I will never get back. Best of luck!


I've had the issue a few times where Fn+F5 just stops working, not showing anything on the screen or a second monitor, and found solutions in using the master physical switch to toggle wireless capabilities and/or reboot the machine to restore hotkey functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.