0

I installed a Lubuntu guest (Ubuntu+LXDE) in VirtualBox on Windows. I also installed the guest additions, however, the clipboard was not working.

To my surprise, there was an option to enable it: Devices->Shared Clipboard, and it was disabled by default!

Is that for all systems, or just for Linux guests? And why would such a user-unfriendly default be set?

3

It's disabled because it violates the default of the virtual machine being entirely sandboxed.

When you run your virtual machine in the default settings, it does not have access to the host OS resources and vice-versa. This includes file-level access, and accessing the clipboard contents. Only the Internet connection is bridged or NATed to allow you to connect to the outside.

Clipboard sharing (much like file sharing) has security-related implications, so you would not want to have it enabled by default.

|improve this answer|||||
  • Well, it made me reinstall several times the Ubuntu guest, thinking maybe something was wrong with the guest additions, or the version (14.04) is too new and still buggy, until I found that option. VMWare enables it by default, so this behavior was surprising to me. – sashoalm May 23 '14 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.