9

How can I check to see if my SSD is running in AHCI mode?

Do I need to install some special driver for that?

Looking for some AHCI indication: Screenshot of my device manager, looking for some AHCI indication

I'm using Windows 7.

4
  • Information like this must be in BIOS.
    – Phoenix
    May 23 '14 at 14:29
  • Yes, I know I need to set AHCI in BIOS, but what about the correct drivers?
    – Pedro77
    May 23 '14 at 14:30
  • @Pedro77 - If AHCI is enabled, just install the AHCI drivers, supplied by the OEM and/or on the product website for your motherboard
    – Ramhound
    May 23 '14 at 14:56
  • 1
    Please don't edit your question into a completely different set of questions, and do you best to stick to one question per question. You wanted to know how to check if AHCI was enabled, you were given an answer, then you changed the question and sprayed multiple new questions onto the end. Instead of doing that, if you have a new/different question, start a new question. May 23 '14 at 17:28
3

Check your BIOS first to see if AHCI is turned on. When you install Windows it installs AHCI drivers and uses it by default (if it's enabled in BIOS). Except for the cases when you may be cloning HDD on SSD.

4
  • 1
    I've accepted an improvement because I simply do not know the answer to whether AHCI is affected by a change from HDD to SSD... from what I've read, AHCI is quite important for SSD as it makes use of new functions SSDs provide... I don't know...
    – Kinnectus
    May 23 '14 at 14:42
  • You know, you can change AHCI settings in a system registry, but if system was cloned and you turn on it - system get crash.
    – Phoenix
    May 23 '14 at 14:49
  • I know that if you install Windows 7 whilst AHCI is turned on then everything gets done automatically, and if you subsequently turn AHCI mode off then Windows still works. If you install Windows with AHCI on then, surely, imaging the device to an SSD will have no ill effects??
    – Kinnectus
    May 23 '14 at 14:56
  • If AHCI was on when Windows was installed on HDD, and then you clone one - it must be OK.
    – Phoenix
    May 23 '14 at 15:18
19

Windows uses AHCI by default, but it may not be enabled if your BIOS wasn't set properly during installation of the operating system.

Check if you're using AHCI mode by viewing the list of controller drivers.

  1. In Windows 7, click the "Start" button > Control Panel > Hardware and Sound > Device Manager

  2. Click the arrow next to "IDE ATA/ATAPI Controllers" to display the list of controller drivers currently used by your system.

  3. Check for an entry that contains the acronym "AHCI." If an entry exists, and there is no yellow exclamation mark or red "X" over it, then AHCI mode is properly enabled. If you don't see an "AHCI" entry, or the only entry contains a red or yellow mark, then there's a problem and AHCI mode is not properly enabled.

Also you can check what is a driver system using:

Right click on one of controllers > Properties > Details tap > Change property to Service

  • pciide.sys = microsoft IDE driver
  • msahci = Microsoft AHCI driver
  • iastor.sys = Intel AHCI/RAID driver

In my system:

enter image description here

Conclusion: My system has no error, it using Microsoft AHCI driver hence AHCI is on.


Please, edit my post if you see any errors (grammatical, technical and etc). Thank you!

1
  • 1
    for me "service" is set to "amd_sata". what does it mean?
    – Gravity
    Oct 17 '18 at 18:46
4

Run AS SSD Benchmark and look under the name of the SSD:

enter image description here

If it is green and shows mv91xx (AHCI driver for your Marvell Controller) you use AHCI if it shows PCIIDE in red you run in IDE mode.

enter image description here

4
  • It shows mv91xx on green. It is odd that when I change BIOS option 2. to AHCI the windows wont boot. If it is already on AHCI because of option 2. it shold have booted. Im confused.
    – Pedro77
    May 23 '14 at 17:28
  • ok, I overlooked that you use a Marvel Controller. In this case mv91xx also means your run in AHCI mode. May 24 '14 at 5:22
  • btw, please don't use such external controller, connect SSDs always to the native SATA ports of the chipset (Intel) May 24 '14 at 5:24
  • Ok, but why? Btw, there are two places at my bios that I can change from IDE to AHCI, at the Onboard SATA6G Controller it was already AHCI, but at Storage configuration / Configure SATA as: was IDE, after I change it to AHCI, Windows did not boot! I'm confused, Win should boot if it was already AHCI.
    – Pedro77
    May 24 '14 at 14:30
-1

You’re using the wrong S-ATA connector on your board. Please consult the manual and connect your SSD to your Chipset-native controller. Which is currently not running in AHCI mode, by the way.

Additional controllers (in this case a Marvell chip) tend to cause problems and often provide inferior performance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.