7

I want to turn off annotations permanently on youtube. I have unchecked the "Show annotations on videos" box, but I still see annotations. Are there any firefox plugins like YouTube High Definition who enforce a setting?

  • 1
    I was able to find an extension for both Chrome and Firefox just by doing a Google search. Just to confirm because there are several questions at http://webapps.stackexchange.com/ you are changing the setting here correct? – Ramhound May 23 '14 at 17:31
  • I didn't vote either up or down, but I imagine the downvotes are because you didn't clearly state what you've done (I know what box you're talking about, but others might not) or why it doesn't work (I know it doesn't work, but others might not). Also, you don't show much research effort (in the question) and this question is a question others might assume is a duplicate. Improve these elements and you may be received better. – Raystafarian May 23 '14 at 18:54
  • 1
    When I uncheck it the annotations go away for me but when I watch next video it will appear again. So essentially I have to disable them every time I open a new video. I believe google should allow me to set that permanently for all the videos I watch once and for all. – RBT Sep 16 '16 at 10:22
6

it can be done with the firefox plugin "UBlock origin".

use youtube.com/watch?v=C5zzVemi3m4

then halt the video when annotations appear and select the proper filters (shorten the filter string to e.g. https://www.youtube.com/annotations_invideo) in the standard UBlock fashion manually.

I am not aware of a shortcut around these manual steps.

This is by far the most superior solution, working permanently in torbrowser asf.. Annotations will still be switched on (according to the "sprocket wheel") but they will not be shown because UBlock filters 100% of them handsomely and forever.

As was pointed out already, most if not all firefox plugins for YT annotation killing do not work any longer. And of course, nobody wants a google account, where disabling annotations will not be honoured by google to begin with.

  • I didn't even think of that, thanks, works flawlessly! – gartenriese Nov 9 '15 at 12:46
7

Go to https://www.youtube.com/account_playback and uncheck "Show annotations, channel promotions and interactive cards on videos"

This will disable the annotations temporarily.

  • 1
    Please read the question thoroughly before answering it. – gartenriese Sep 18 '14 at 14:18
  • Works for me (Chrome), Are you logged in?, Are you using private browsing? – David Sep 26 '14 at 5:58
  • 2
    Somehow Youtube keeps resetting that preference for me, I've disabled it at least 10 times over the last few years but every few months it re-enables again. Am I the only one with that issue? – Wolph Jan 20 '15 at 0:26
  • 1
    @Wolph: You're not, that's why I asked the question. – gartenriese Sep 14 '15 at 22:17
  • 1
    @gartenriese: thanks for the explanation. In that case this answer should be deleted... – Wolph Sep 14 '15 at 22:19
4

You can use Smart video for Firefox to disable annotations

  • open preferences
  • Check the Hide annotations by default option Imgur

Not the answer you're looking for? Browse other questions tagged or ask your own question.