0

I don't reboot my mac very often, so I can't really state if this occurs with every reboot/relogin, but I dare to say, pretty much every time the font rendering of my iterm2 becomes thicker or thinner after the reboot. There are still regular differences visible for bold or non-bold fonts, ie. in weechat, in any case, but the overall type face toggles (see attached screenshots). It is the same font (11pt Menlo regular) and the checkmark at "anti-aliased" is always set for both regular and non-ascii fonts.

This has happened for years, so this is not version-specific. Also, it does not interfere my workflows in any way, it just bothers me that it looks different all of a sudden every now and then.

Has anyone else experienced it? How can I stop this from changing the type face? This is on an MBPv3,1 running OSX Lion. I was trying to post this in the google group but my account was not able to post there.

bold font thin font

1
  • The second screenshot looks like LCD font smoothing (subpixel rendering) is turned off. You could try to quit iTerm and run defaults write com.googlecode.iterm2 AppleFontSmoothing -int 2 in Terminal, but it won't probably help.
    – Lri
    May 30, 2014 at 17:26

2 Answers 2

0

I've never experience what you're describing, but it looks like the first font has Antialiasing ON and the second Antialiasing OFF. You sound like you know what you're doing (in general) in the Default Profile settings, so here's a suggestion:

A decent troubleshooting approach would be to:

  1. Backup the preferences plist file for iTerm located in ~/Library/Preferences/com.googlecode.iterm2.plist
  2. Quit iTerm2.app completely.
  3. Destroy the plist preferences cache with Terminal.app and: $ killall cfprefsd
  4. Relaunch iTerm2.app and adjust your Default Profile settings to some peculiar and obviously different font settings.
  5. Reboot/Re-login and see what happens.

If the above doesn't work, I would try using another font and test the waters with that?

Perhaps look at the dotfiles with ~ $ ls -la and see if anything interesting is in .bashrc, .profile, etc.

1
  • No difference, sorry. It just switched back to the thinner one now, even with a different font (Lucida Console). Btw, both screenshots have Antialiasing ON, antialiasing OFF looks like this
    – mcnesium
    May 26, 2014 at 10:34
0

You can adjust this behaviour using the "Use thin strokes for anti-aliased text" setting in the Profiles->Text preference section.

enter image description here

The default appears to be "On Retina Displays", so my guess is that on reboot your display is being detected as a Retina display only some of the time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.