7

I've recently acquired a Samsung Evo 840 120GB, but haven't been able to actually use it.

The problems started when trying to do a fresh install of Windows 8 on it: Win8 Install

I've retried the process with the HDD disconnected, to no avail.

Then, I've decided to check the SSD's status on DISKPART:

http://i.imgur.com/2y0vKUN.jpg

Switching SATA cables and ports (and even trying on another computer to eliminate the chance of it being a MOBO incompatibility) give the same result.

Finally, I downloaded the Samsung Magician software to check the disk status (Windows was temporarily installed on the shown HDD):

http://i.imgur.com/E1JkBuw.png

The complete red message says "SSD is in the locked state".

I am unable to do a Secure Erase (both Magician and Parted Magic bootable solutions fail).

S.M.A.R.T. fails, but it seems like the values are "generic": http://i.imgur.com/R0S4y89.png

Going into Disk Management, I receive the following warning:

http://i.imgur.com/RzZBlaY.png

However, choosing any of the options results in this error:

http://i.imgur.com/hYu2hce.png

Which leaves the disk locked from any space manipulation (creation of volumes/partitions/formatting/etc).

And now I'm stuck. Everything shown here can recognize the SSD (and it's size, including the BIOS/UEFI), but nothing seems to be able to actually write in it.

Is the SSD faulty or is there another step I can take in order to check it's health (and actually make it work)?

9
  • this link suggests that you set the SATA controller mode to IDE instead of AHCI. – Mixxiphoid May 24 '14 at 19:38
  • Just tried that; the Windows installer now fails with a new error (0x80300002) and the Magician bootable secure erase still can't finish the erase without failing. – ememorais May 24 '14 at 20:32
  • So the windows installer was able to access the partition? Something else you can try: Before starting the setup press shift + F10 to get the command prompt. Then start diskpart, type list, type select {your disk}, type clean. See if that helps. to leave diskpart type exit. – Mixxiphoid May 24 '14 at 21:16
  • It can see the unallocated space, but can't create a partition. I tried using diskpart; The second image shows the output. The clean succeeds, but it can't create a partition because of a "I/O Error". – ememorais May 24 '14 at 21:44
  • I guess I was sleeping, didn't read the full text of the second image. I did some searching and found only users who returned their entire pc (they bought it as a whole) and it was fixed. Not really helpful, but it seems to most practical solution to return the SSD. – Mixxiphoid May 24 '14 at 21:55
1

Sounds much like a controller problem on the SSD. Samsung doesn't have a lot of problems with their controllers (unlike OCZ for example), but they do happen.

Return the drive and have a new one sent to you. New drives shouldn't cause all that much trouble. Samsung EVO drives are generally plug and play. If your other sata drives are working with the configuration you have, so should your SSD.

0

Here is how I solved it - The key is NOT to have your SSD's power connected during boot. You want to connect it's power ONLY AFTER you enter the program that you are using to secure erase it:

use the official Samsung Magician (SM) software to Secure Erase, but I am sure these instructions will work just fine with Parted Magic (Use steps 2,3, 4 and 6 for Parted Magic)

  1. Create your Secure Erase boot medium with SM (USB or CD).

  2. Completely power off the computer.

  3. Open the chassis and disconnect the power cable to your SSD drive.

  4. Power on your computer and boot to your Secure Erase medium.

  5. It will error out and return you to the DOS prompt.

  6. WHILE KEEPING YOUR COMPUTER POWERED ON, open the chassis and reconnect the power cable to the SSD drive.

  7. Type SEGUI0.EXE to open the Secure Erase software again. Note: If it opens with an all blue screen and red border, press esc a few times to get back to the DOS prompt. Run it again with /s at the end (e.g. SEGUI0.EXE /s).

  8. Run the procedure again and this time it won't say it is frozen and it will erase

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.