34

I am running Ubuntu and Linux Mint in VMWare. In the display settings, none of the 16:9 aspect ratio resolutions are available, including the commonly used 1920x1080 resolution. How can I enable this?

6 Answers 6

63

Enter the following commands in a terminal to enable 1920x1080 resolution:

xrandr --newmode "1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode Virtual1 1920x1080
xrandr --output Virtual1 --mode 1920x1080

This will set your display resolution to 1920x1080 and also enable several other 16:9 aspect ratio resolutions in the display settings.

Remember that you may have to enable full screen mode in VMWare before these resolutions become selectable.

9
  • I was having this problem and found the solution on this webpage: techsfo.com/blog/2013/07/1920x1080-ubuntu-vmware I'm sharing this question and answer because it seems to be a frequent problem experienced by people running any kind of Linux distribution in a virtual machine. I really don't understand how the command works, so if someone would be willing to explain what the various numbers mean (besides the obvious resolution dimensions) that would be most welcome. May 25, 2014 at 5:19
  • Hi Brain, what should be done for 1366x768 resolution ?
    – Rajasekhar
    Feb 5, 2015 at 6:39
  • 3
    Worth noting that you should identify your display first, using xrandr. Mine is VBOX0 instead of Virtual1.
    – Tass
    May 4, 2015 at 20:56
  • 1
    It worked! I could kiss you :)
    – Manu
    Oct 4, 2015 at 11:08
  • 1
    Oh. It goes back to a small resolution after a restart :(
    – Manu
    Oct 4, 2015 at 11:24
9

@InvalidBrainException's answer is great. In addition, in order to it make it permanent and prevent running commands on each restart, you can write the following configs into file /etc/X11/xorg.conf.d/10-monitor.conf:

Section "Monitor"
    Identifier "Virtual1"
    Modeline "p1920x1080"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    Option "PreferredMode" "p1920x1080"
EndSection
3
  • 2
    If you need to improve on it, it isn’t perfect, is it?    :-)    ⁠ Oct 3, 2017 at 21:44
  • 2
    This is amazing, and exactly what I was looking for. Takes effect after reboot, and effectively sets the resolution for the login screen!
    – Nate
    Apr 12, 2019 at 1:13
  • I don't have /etc/X11/xorg.conf.d ...
    – yehudahs
    Jul 17, 2021 at 6:03
3

@mhsekhavat Years later... Ubuntu 20.04 on vbox 6.1.

  1. Stick the 10-monitor.conf in /usr/share/X11/xorg.conf.d/
  2. Reboot
  3. 1920 x 1080 should now be available in the Ubuntu Settings > Screen Display
  4. Select it and Apply and Keep Changes

Now on reboot it should remember!

1
  • does not work. I cannt see it there Aug 30 at 19:07
0

Running Ubuntu in VirtualBox, I had this issue, and the issue with the resolution being forgotten on restart (reported elsewhere). Both issues were fixed for me by following method 2 in:

https://linuxhint.com/change-resolution-of-a-linux-vm-in-virtualbox/

In summary it says that after installing dkms you should "insert" and run the host specific Guest Additions CD image then restart.

-1

Try this on Virtualbox:

sudo cvt 1920 1080 60    
sudo xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
sudo xrandr --addmode Virtual1 1920x1080_60.00
-2

You can take the script from InvalidBrainException and...

  • create a 1920x1080.sh file
  • make it executable
  • add it as a startup script so that it is run on system startup

Otherwise you'll have to run these lines after each startup manually.

Not the answer you're looking for? Browse other questions tagged or ask your own question.