12

Recently, Geany suddenly started showing underscores as spaces - i.e. they've become "invisible".

For example this text - is_empty, displays the same as is empty. But when copying to the clipboard from Geany, the underscores are as they should. They're only displayed wrong.

  • Do they become visible if you change the font? – user33758 May 25 '14 at 16:08
  • Yes, that fixed it. But if I set it back to Monospace the problem returns. Now I need to find some other monospace font to use with Geany, it seems. Hm, the problem is there with 'leafpad', as well - it uses Monospace, too. Also, sometimes the underscores appear, if I move the cursor on the same line (with leafpad at least). If I move the cursor away, the disappear again. – sashoalm May 25 '14 at 16:11
  • @screener It seems it's a Monospace bug, not a geany bug, there are a lot of hits for that problem - google.com/search?q=monospace+invisible+underscore – sashoalm May 25 '14 at 16:17
4

Same issue, Ubuntu 20.04

The problem is well described here:
https://github.com/geany/geany/issues/1387#issuecomment-287537022

Some fonts write underscores below descenders but don't include that in the declared font height, this is technically incorrect and confuses the layout software in Scintilla (the editing widget Geany uses) so insufficient height is allowed for underscores.

The solution is to either change font or to instruct Geany to make line height bigger:

Tools > Configuration Files > filetypes.common

[styling]
line_height=0;2;
| improve this answer | |
5

It turned out that the problem was with the Monospace font. This happens also with other programs, such as LeafPad if they use that font.

The solution was to change the font to something else - "Lucida Console" in my case.

Edit: It seems that changing the zoom fixes it, too. Some zoom levels have invisible underscores, some don't.

| improve this answer | |
  • Yes, zooming with Ctrl + Scroll seems to solve the issue – Covich May 7 at 15:08
4

For future reference, I had the same issue with Monospace 14 in Kubuntu 16.04, and it was solved by installing the recommended nvidia driver for my graphic card.

Edit: Despite the anonymous downvoter, this solution worked for me and I discovered it by chance. It means that it is a display problem. I didn't find any reference to this with search engines, so I'm pretty sure it can help someone to find it here.

| improve this answer | |
2

Sorry for the very late answer, but this problem still persists.

For me, this was fixed by changing the font-hinting setting from 'slight' to 'medium', which looks like a bug to me.

I am using Cinnamon but I guess this would also work in other desktop managers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.