When accepting a picture via Bluetooth I accidentally enabled the checkbox Always do this for Image files from ...

Now pictures are always accepted from this device and I am unable to change the folder to save them in.

How can I reset this setting so the dialog appears again?


The Bluetooth stack

First of all, even though in Windows 7 the Bluetooth settings dialog always looks the same, there are at least two different Bluetooth stacks available which differ significantly in capabilities.

One of them (Microsoft/Widcomm/Broadcom?) can easily be recognized because it has the Bluetooth Device Control window that opens when you double click a Bluetooth device in Devices and Printers. This one is also the one that has the dialog mentioned in the question.

The other one (Toshiba?) features a "Receive file" entry in it's Bluetooth tray icon menu and does not have these Bluetooth Device Control windows. The question (and answer) does not apply to this kind of Bluetooth stack.

Reset the setting

The UI method

If you feel uncomfortable editing the registry there is a UI method to re-enable that dialog, however it's a bit cumbersome.

  • First you need to pair the device in question.
  • Then doubleclick it to open the Bluetooth Device Control window
  • Scroll down to the Authorization Options section and expand it
  • Switch to Always allow this device to connect for all operations and Apply
  • Switch back to Require confirmation for all operations to and from this Bluetooth device and Apply
  • You can now unpair the device again

The next time you send a picture from this device, the file receive dialog will appear and give you the chance to choose the destination folder for the received file again.

The Non-UI method

If you do feel comfortable editing the registry, it's much easier:

  • Go to HKLM\SOFTWARE\Widcomm\BTConfig\Devices (not HKCU, there is a very similar subtree there which I found to have no effect whatsoever)
  • Find the device in question by it's MAC address or by doubleclicking the Name value
  • Set the ImageFileOption (or AudioFileOptionetc.) value to 0 (or just delete the whole device key to reset all setting to default)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.