I pretty much summarized the problem in the title. I tried to get some solutions. All I found was check if the Chrome has any concurrent or erroneous applications installed on my computer that conflicts with Chrome (by typing chrome://conflicts).

But "unfortunately" it said that there are no perceived conflicts. First I thought it is only with Chrome, but soon I saw that no. All internet browsers are affected.

I noticed this problem after I installed Fruity Loops, but uninstalling it didn't solve the problem. Maybe Fruity loops is not the guilty reason.

Have any of you met this problem before? What should I do? Thank you.

UPDATE: Sorry I forgot that this is under Windows 8.1.

  • What OS (make/edition/version?) Have you tried it while logged in as a different user? Have you tried disabling all unnecessary start-up services and applications to see if it helps? If it's Windows, have you tried it in Safe Mode with Networking? May 26, 2014 at 20:21
  • Windows 8.1 (Microsoft). No, I haven't. No, I haven't. No, I haven't. Logged in as a different user sounds good, I'll give it a try. Thanks. May 26, 2014 at 20:53
  • 1
    To the two minus voters: please explain why you -1'd it. Thanks. Mar 4, 2016 at 10:02

8 Answers 8


The download/upload dialog is just the common dialogs function of Windows. I expect that this problem also exists when using file->open or file->save as in some programs.

I would suggest doing sfc /scannow to scan for corrupted/missing Windows system files. You need to run a command prompt as administrator to run this utility.

  • The result is: Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not supported in offline servicing scenarios. And in the log file, there are only 3 error entries, all 3 are something about 'Failed to resolve package xy... blabla". There are no matches to "Chrome" or "exception". What should I search for? It's 45k lines... May 26, 2014 at 20:46
  • Chrome failing is the result of another issue. The sfc /scannow shows what the main cause is. The 45k lines are the log of the problem, its all in there. Its likely that there are 45k files of one component and reinstalling that one component fixes your issue. Try googling for the items in that list.
    – LPChip
    May 26, 2014 at 21:29
  • 1
    @Mitulátbáti See this answer. Then report back the details in your question.
    – and31415
    May 26, 2014 at 21:44
  • Ok, as soon as I get the solution. Jun 2, 2014 at 21:25

I chased a lot of things when this happened to me - Easiest way out is to create a new user and copy all your stuff over - alternatively create a new user and then use Windows Easy Transfer to move to the new account. The problem will clear itself with the creation of the new account.


Was facing the same issue from a long time.

Got it fixed. Just follow these easy small steps

1) Open any Windows explorer window

2) Select View

3) Select Options

4) Under Navigation Page - un-select option -> Automatically expand to current folder.

This should fix your problem as it fixed mine.


The same thing occured to me some time ago. All internet browsers crashed whenever a link between browser and file explorer was made, downloading or uploading a file. Next I noticed it affected MS Word too. Saving existing document worked fine, but Word crashed when trying to save it as a new file (file explorer opens).

I tried sfc /scannow several times with CMD opened as adminstrator and it always stopped at 27%. I can't remember the error, it was something like "could not execute" or something. I am using Finnish version of Win7 so sorry for bad translation.

After that I tried sfc /verifyonly (as per www.sevenforums.com). There was no problem with that, but even after that /scannow stops at 27%. Then I tried (at cmd again) Dism /Online /Cleanup-Image /RestoreHealth (as per forum.thewindowsclub.com). Cmd says there is no such funcion, so i tried same but instead of /restorehealth I used /scanhealth or /checkhealth (can't remember which). This was executed well to the end and after this I can use sfc /scannow and it completes. I did it 3 or 4 times as instructed.

There was also some windows updates involved, and I reinstalled some of basic drivers with acer recovery tool.

After restart, all works again! Even the old problem that I had before was gone. The old prolem was that I could not install a printer or "print" a PDF file because some of the printer services were down and windows was not able to start them. Now printing works also.

Just thought that this would be worth sharing, this is kind of unique problem and there will be people struggling with it in the future.


I fixed this, in Windows 7, by turning off the preview feature in Windows Explorer (that's the file explorer, not a browser). To do this, open a directory in Explorer. Go to Organize | Folder and search options | View | Uncheck: Show preview handlers in preview pane | Apply and Apply to folders.

Before, this happened periodically in all my browsers: Firefox, Chrome, Opera, and Internet Explorer.


Windows 7 Fix:

Open Windows Explorer

Click the Organize button

Choose Folder and search option

Switch to the View tab

Click the Reset Folders button, then Yes

Click the Apply to Folders button, then Yes


It's been late for this question, but this happened on my computer just today, hence I'm posting my findings here (for Windows). I don't think it has anything to do with the browsers, and that's why it happens across all browsers.

The culprit is 'explorer', as has been hinted in some of the other answers. Giving below my quick and dirty solution.

1. Mostly task manager also goes unresponsive whenever this happens. If that happens we'll have to kill the browser - use an elevated command prompt to run the command:

taskkill /f /im microsoftedge.exe


taskkill /f /im chrome.exe

or similarly for other browsers.

  1. Then use task manager to kill the explorer (and start it again). Browser should work fine now.

Or we can directly kill 'explorer' using command prompt (using a command similar to the ones shown above), I haven't tested that yet.


here is what happened in my case.... Before i installed Apple quicktime and Itunes, ive never had this problem. While i had apple quicktime and itunes installed every browser ive used had the problem of freezing up or crashing when trying to save a file. (Firefox, Chrome, Internet Explorer). since i've uninstalled apple quicktime, itune and all of it's addition software.. (automatic updates, icloud, bonjour, etc), i have never had this problem again. There's your answer. apple updates is installing software that's causing browsers to malfunction. If you dont believe me, uninstall all apple products and see if the problem goes away.

  • This does not really answer the author's question.
    – Ramhound
    Jul 26, 2015 at 22:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .