0

I have 2 pcs with win xp and a wifi router ( without outgoing internet connection )...my job was to connect them over wifi to share some files. router was properly configured, both computers connected to wifi without problems, but when I tried to network them I could not see them in workgroup...i changed their names and added them to same workgroup but i couldn't connect pc1 to pc2 ( i could ping router from each pc but pinging other computer resulted in ping timeout) ..now i cant figure out why this is not working since I've done this before on more complex networks and it should work but...( maybe I have gremlins hiding somewhere..)

edit1: Firewall is down on both machines( I disengaged it in both control panel and in services) and folder sharing and permissions are ok.. edit2: I know about Ad Hoc network ( wlan-to-wlan, without router/switch ) but that's not what I am trying to accomplish here :)

  • If I were you, I would leave the sharing out for now. Start with simple things. Make sure your two PCs can "see" each other. If you cannot ping, then there is no point to start setting sharing up. – Art Gertner May 27 '14 at 9:08
  • Would you look through the router settings and see if there are some restrictions there? Possible router has a firewall or something similar too. You might want to check it – Art Gertner May 27 '14 at 9:09
  • Well, router conf is ok, I tested it in controlled enviroment first,with several other PCs with different OS and settings and it workd fine, also at deployment site i tried with static ips and other dhcp and other router... – zsn May 27 '14 at 9:19
0

First thing to do is to disable the firewall. Don't consider this as a permanent solution. This is just a way to find if the firewall is blocking your requests. I have seen very similar problems before and 9 cases out of 10 it was the firewall.

So go to your Control Panel > Windows Firewall or any custom firewall you are using and disable it on both machines. Then try to ping / connect.

Also, when pinging and attempting to connect make sure you are using IP addresses, not computer names, then you at least know that this is not your host-name resolution service that is failing.

| improve this answer | |
  • I guessed it could be firewall issue but it isn't; pinging resulted in timeout... – zsn May 27 '14 at 8:52
0

As it turns out, one of the machines had a win xp home without updates and networking limitation that prevented the computer itself workgrouping with other winxp pro computer.

I solved the problem by making ad-hoc connection with one pc being gateway to another over wireless connection( pinging is still the issue because packets got lost 25-50 % ) and making a shortcut to shared folders...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.