7

I have been trying to open Google Chrome from command line but with no luck! I have tried How do I start Chrome using a specified "user profile"?

My goal is to open Google Chrome with a specific profile such as "profile 1", "profile 2", or "Default" from the command line, using bash to be specific, on my Mac.

UPDATE: 6/3/14 Got this to work BUT only works when opening chrome for the first time

open -a Google\ Chrome --args --"profile-directory"="Profile 1"

So How do you get --args to be accepted AFTER google chrome as already been launched??

  • What parts of the linked question did you try and what didn't work about them? – Jason Aller May 28 '14 at 4:26
  • 1
    'open -a "Google Chrome" --args --profile-directory=Default' Which in the same thread says this no longer works as of Nov 2014 Also tried 'com.google.Chrome --args --profile-directory=Default' After following his comment, tried it with it it hanging on that exact line, no erros, no chrome opening – gradedcatfood May 28 '14 at 4:32
4

You could try the following:

/Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --args --profile-directory=Default

Referred from this answer.

  • That was a thread i opened on stack overflow and they sent me here. that didn't work. --args --directory-profile="PROFILE_WANTED" Dosnt work for me :/ – gradedcatfood May 31 '14 at 2:45
4

To force a new profile window after Chrome has been launched:

open -n -a "Google Chrome" --args --profile-directory="<your profile>"

(where <your profile> is one of the Profile nn folder names found in ~/Library/Application Support/Google/Chrome/)

According to the manpage for open, the -n flag forces "a new instance of the application even if one is already running." You'll see second Chrome icon flash open briefly in the dock while the window loads but everything runs normal after that.

  • What's the point of --args? – Pacerier Sep 8 '17 at 14:31
  • 1
    @Pacerier per the man page for open: "--args: All remaining arguments are passed to the opened application in the argv parameter to main(). These arguments are not opened or interpreted by the open tool." In other words, we're specifying that --profile-directory is a switch for Chrome and not for open itself. – rymo Sep 8 '17 at 15:59
  • Seems to open a new profile even when the name is right. Also tried using the full path to the profile and still getting a brand-new profile each time. Has something changed? – tgf Apr 24 at 16:17
1

Try: open -a "Google Chrome" --args --profile-directory=<your profile name> Works every time for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.