3

I have an email address of the form user@something.com that I am accessing through this site. I had connected my email to Outlook 2010 and it was working fine. Recently, it started requesting credentials every time I logged in, without connecting to the email server even after entering the correct password. I had already decided to reinstall Windows 7, so I thought that would also fix this problem. Unfortunately it did not.

I tried the troubleshoot function embedded in the Office 365 capabilities, but it did not find anything wrong. I suspect that one possible source of this problem could be the fact that in the control panel it states Mail (32-bit) while Windows is 64-bit (office is 32 as well).

In addition when trying to remove an email account from the list it remains there unaffected.
Does anybody know what should I do in order to fix this problem?

2

I found the resolution to this issue a few weeks back and due to me being lazy I have yet to publish the full resolution on by blog. So I now have to write it up for you. Please follow the below to the letter and I guarantee it will work.

  1. Install Microsoft Office 2010 SP2. (download links towards the middle of the page)
  2. Restart if required, now remove all email profiles on the machine via the mail (32bit) utility
  3. Create a new mail profile and open Outlook
  4. When the wizard loads choose to configure a new exchange account
  5. For the server enter: outlook.office365.com
  6. Email and password should be the Office 365 email and password
  7. Click "More Settings" in the bottom right
  8. Under the Advanced tab uncheck "Download shared folders".
  9. Under the security tab, in the "Logon network security" drop-down select Anonymous Authentication.
  10. Under the 'connection' tab check "Connect to Microsoft Exchange using HTTP".
  11. Click "Exchange Proxy Settings" use the URL: outlook.office365.com
  12. Tick "Only connect to proxy servers that have this principal name in their certificate" and enter: msstd:outlook.com (Please be aware that there's a typo in the screenshot below; the description here is correct.)
  13. Check both the checkboxes
  14. Under "proxy authentication settings" drop down select "Basic Authentication".

Now reload Outlook and sign in at the first prompt. Be sure to check "Remember password".

Screenshots for reference:

Step 8 Step 9 Step 11 to 14

3
  • There is a typo in step 12. It should read: msstd:outlook.com
    – user452469
    May 27 '15 at 19:26
  • This Guide Worked perfect but If anyone is still having issues you will need to disable MFA on O365 for the user.
    – PloxPanda
    Jun 19 at 7:58
  • Is this solution still valid now in 2021? I was able to connect Outlook 2010 to office365.com (exchange?) server about a year + ago. Now I am trying again with different server and didn't have any success. Could that be because Office 2010 is now abandoned by Microsoft or should I look into the MFA path? Oct 2 at 4:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.