2

At this point, I'm hoping that I'm making a really stupid mistake but...

I cannot get One Drive for Business to sync with Office 365 on multiple domain attached machines. When I do this, it doesn't produce any type of error message (either on screen or in the error logs) but it just stalls on the 'We're getting files ready to sync...' stage.

I've tried multiple OS'es, both real and virtual machines, and it always fails on domain attached machines. The thing is that it worked just fine at first time.

We use Office 365 authenticating by ADFS for the signin and that appears to work fine. i.e when I connect to a Sharepoint site, I can see the sites that I can sync to and start the process just fine, so I don't think it's an authentication problem.

On a non-domain attached machines, it works absolutely fine.

Looking to see if anyone has any ideas!

5
  • Do you have any group policy firewall rules recently modified or added that are being applied when the machine is joined to the domain? This doesn't normally happen if templates are used but your admin may have tweaked some settings... – Kinnectus May 28 '14 at 11:31
  • I'm afraid we don't on this. All off this is done by the main firewall, there's nothing specific on the machines. – carpo May 29 '14 at 10:54
  • MS recon it's do with the permissions on the Program Files folder, but I'm doubting that to be honest as they are the same on the non-attached accounts and working fine. – carpo May 30 '14 at 11:36
  • What version of Windows are you using? The troubleshooter "fixit" tool found on the Windows site fixed my no-error OneDrive problem, but it only works for Win8.1: windows.microsoft.com/en-ca/windows-8/… – cathoo Jun 5 '14 at 23:14
  • Windows 7 or Windows 8.1 but as this is a sharepoint link that we want to access, we are using MS Onedrive for Business 2013 as comes with MS Office 2013 – carpo Jun 10 '14 at 8:41
0

I spent hours on this (or something similar), reading numerous online posts from others who also had similar problems. The nightmare began when I ran "repair" because I felt like the file transfer was going much too slowly. Now it is working (although still slow), maybe due to some inspiration I found in the question posted here.

Here's the sequence that ultimately prevailed (although I'm not really sure why)...

  1. run the OneDrive for Business Easy Fix tool -- this never completed, but it definitely did remove some files from my file system, so maybe it was an important step.
  2. Log out and log back in on using my domain password instead of my "virtual digital badge" -- this seemed to be the main thing that was different the time it finally worked (By the way, I am connecting remotely at the moment).
  3. Attempted to Sync from the Office 365 OneDrive web site, but this ultimately did nothing, while claiming to succeed (as usual): "Your files are syncing as we speak", while I was still seeing "no libraries are currently connected" on the notifier -- utter nonsense.
  4. Used the normal mechanism to Sync a new library from the OneDrive notification icon -- used the URL from Office 365 up to and including my user name.

I had previously done numerous variations of all but step #2, so it seems like step #2 was the ultimate solution -- and I got the idea for that from the wording of this question.


If you go to "Manage Storage"->"View OneDrive for Business storage" you may see a long list of folders. I see, for example:

  • Documents
  • Form Templates
  • Style Library

In some of my previous attempts to Sync a new library, it would ask me to choose between "Form Temp" and "Style Lib", when what I wanted was in the "Documents" folder. I have no idea what it was thinking, but this final time it didn't ask -- it just started syncing with "Documents" as desired.


It didn't help that the broken dialogs would give folksy messages like "This shouldn't take long...", which usually turned out to be false.


In conclusion:

Dear Microsoft,

The web interface works great. Is it really so hard to attach to the same URL using a dedicated application?

2
  • I just noticed that my files are being populated in a folder called "OneDrive", whereas I think they were previously in "OneDrive for Business". – nobar Oct 14 '16 at 20:39
  • While your at it, when I type my password wrong, don't say "Welcome" for 30 seconds before telling me I got it wrong. ;) – nobar Oct 14 '16 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.