I have a Windows 8.1 PC that I had to install Rutoken Drivers utility on. Apparently older version uninstall has done some damage to Windows driver store and now I receive a 1603 Windows Installer error whenever I try to install the package. I have narrowed the problem to installing/uninstalling drivers via pnputil returning error 13 (0x0D) with the description "Invalid data". What data is invalid is beyond my comprehension.

The trouble is that now I cannot install any driver, and either pnputil or its wrapper or underlying API call returns the same 0x0D error in my face. I have tried sfc /scannow with zero errors, dism /online /cleanup-image /scanhealth - 1 "payload corruption" and failure repairing that "corruption" with 0x80240021 (timeout downloading from Windows Update - the affected package does not exist in there).

Searching Google did not return any additional possible actions. I have even tried to manually remove all registry entries that include the info on these drivers along with all the files in both %SystemRoot%\inf and %SystemRoot%\system32\DriverStore\FileRepository, this resulted in drivers officially being uninstalled, thus I receive 2 less errors while installing that package, but the main problem persists. I am out of options barring Windows reinstall, but this is yet not allowed because of sensitive payload running on the server.

Is there any way to repair the metadata in Windows 8 driver store?

UPDATE: Relevant portion of setupapi.dev.log follows. This is the part with the first recorded error:

[Boot Session: 2014/04/30 10:21:02.496]
>>>  [Device Install (DiShowUpdateDevice) - USB\VID_04A9&PID_3155\D1FD7268198E4248B690D4C39EF7FA4D]
>>>  Section start 2014/05/20 13:12:15.744
      cmd: "C:\WINDOWS\system32\mmc.exe" "C:\WINDOWS\system32\compmgmt.msc" /s
     dvi: {DIF_UPDATEDRIVER_UI} 13:12:15.757
     dvi:      No class installer for 'Canon Digital Camera'
     dvi:      No CoInstallers found
     dvi:      Default installer: Enter 13:12:15.766
     dvi:      Default installer: Exit
     dvi: {DIF_UPDATEDRIVER_UI - exit(0xe000020e)} 13:12:15.771
     ndv: {Update Driver Software Wizard for USB\VID_04A9&PID_3155\D1FD7268198E4248B690D4C39EF7FA4D}
     ndv:      Driver package 'C:\WINDOWS\INF\wpdmtp.inf' exists under 'C:\WINDOWS\System32\DriverStore\FileRepository\wpdmtp.inf_amd64_5c9850dbde92cf4e\wpdmtp.inf'.
     dvi:      Searching for hardware ID(s):
     dvi:           usb\vid_04a9&pid_3155&rev_0001
     dvi:           usb\vid_04a9&pid_3155
     dvi:      Searching for compatible ID(s):
     dvi:           usb\class_06&subclass_01&prot_01
     dvi:           usb\class_06&subclass_01
     dvi:           usb\class_06
     dvi:      Class GUID of device changed to: {eec5ad98-8080-425f-922a-dabf3de3f69a}.
!!!  ndv:      Device install failed for device.
!!!  ndv:      Error 13: The data is invalid.
     ndv:      Installing NULL driver.
     ndv: {Update Driver Software Wizard exit(0000000d)}
<<<  Section end 2014/05/20 13:12:23.679
<<<  [Exit status: FAILURE(0x0000000d)]

This part is what happened at reinstallation of Rutoken Drivers:

>>>  [SetupCopyOEMInf - C:\WINDOWS\System32\DriverStore\FileRepository\rtusb.inf_amd64_19d5bedeabf631df\rtusb.inf]
>>>  Section start 2014/05/26 18:28:17.278
  cmd: C:\Windows\System32\MsiExec.exe -Embedding D9545376710EF829AA7DF44D8CF55F60 M Global\MSI0000
 inf: Driver Store Path: C:\WINDOWS\System32\DriverStore\FileRepository\rtusb.inf_amd64_19d5bedeabf631df\rtusb.inf
 inf: Published Inf Path: C:\WINDOWS\INF\oem8.inf
<<<  Section end 2014/05/26 18:28:17.278
<<<  [Exit status: SUCCESS]

>>>  [SetupUninstallOEMInf - oem8.inf]
>>>  Section start 2014/05/26 18:28:17.356
      cmd: C:\Windows\System32\MsiExec.exe -Embedding D9545376710EF829AA7DF44D8CF55F60 M Global\MSI0000
     inf: Driver Store Path: C:\WINDOWS\System32\DriverStore\FileRepository\rtusb.inf_amd64_19d5bedeabf631df\rtusb.inf
     sto: {Setup Delete Driver Package: C:\WINDOWS\System32\DriverStore\FileRepository\rtusb.inf_amd64_19d5bedeabf631df\rtusb.inf} 18:28:17.356
!!!  sto:      Failed to call to delete driver package. Error = 0x0000000D
     sto: {Setup Delete Driver Package - exit (0x0000000d)} 18:28:17.372
!!!  inf: Failed to delete package from Driver Store
!!!  inf: Error 13: The data is invalid.
!!!  inf: Error uninstalling OEM INF 'C:\WINDOWS\INF\oem8.inf'
!!!  inf: Error 13: The data is invalid.
<<<  Section end 2014/05/26 18:28:17.387
<<<  [Exit status: FAILURE(0x0000000d)]

Since then every install/uninstall fails with 0x0000000D.

  • The tool you would normally use for this is DISM there really isn't another tool. Are you able to use a restoration point?
    – Ramhound
    May 28 '14 at 12:20
  • No, the server in question does not have a RP. I've tried DISM already to no effect, sadly.
    – Vesper
    May 28 '14 at 12:23
  • 1
    You can supply DISM an external image from the one that is contained within your system just have to have an .ISO or a Windows 8 installation Disk
    – Ramhound
    May 28 '14 at 12:43
  • Hmm, indeed, trying right now.
    – Vesper
    May 28 '14 at 13:20
  • Well, it did fix the detected 1 corruption, but the driver installation still fails with the same error.
    – Vesper
    May 28 '14 at 13:42

The apparent answer is no, you cannot fix the driver store. Ended up reinstalling Windows just for that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.