0

We configured sudosh on AIX as login shell with /usr/bin/bash as their default shell.

All is working fine except bash autocompletion and command history are not working anymore. TAB is TAB, arrows is cursor up, down, left, right.

Any idea how to get this working?

0

I don't know sudosh, it seem very old.

First you have to know witch profile to load, is it .profile, .bash_profile, .bashrc ? Can you show us your PATH?

echo $PATH

should return something, if not, that is why the TAB doesn't work.

About the command history, you have to check if you have a .bash_history inside your home directory with the right permission and ownership.

Type this command to see if you have an history :

history

If not, check what i told you.

It can help me if you can post an ls -l inside your home

-1

Should load .bash_profile because bash is configured as default shell.

    $ echo $PATH
echo $PATH
/usr/bin:/etc:/usr/sbin:/usr/ucb:/usr/bin/X11:/sbin:/usr/java6/jre/bin:/usr/java6/bin
$ history
history
    1  echo $PATH
    2  history
    3  ls -la
    4  cat /dev/null > .bash_history
    5  ls -la
    6  exit
    7  echo $PATH
    8  history
$ ls -l
ls -l
total 0
$ ls -la
ls -la
total 24
drwxr-xr-x    2 srarol   staff           256 Jun 11 09:39 .
drwxr-xr-x   14 bin      bin            4096 May 15 16:00 ..
-rw-------    1 srarol   staff            68 Jun 11 09:40 .bash_history
-rw-r--r--    1 srarol   staff           255 Jun 11 09:37 .bash_profile

>>cat .bash_profile
# Local Environment
PS1='\[\e[1;36m\]${ORACLE_SID}\[\e[1;35m\] \[\e[1;33m\]\u\[\033[1;35m\]@\[\e[1;32m\]\h\[\e[0m\] $PWD $ '
EDITOR=vi

export PS1 EDITOR

# vi parameter AIX
case `uname` in
  AIX) EXINIT="set ll=20000000"
       export EXINIT
    ;;
esac
  • This doesn't really answer the question, does it? .bash_profile is just a file, but clearly it doesn't have the right contents or there is some other problem. Posting a directory listing of your own machine isn't an answer. – mtak Jun 11 '14 at 8:01
  • Sorry? It should load .bash_profile. I have a .bash_history file with the correct permissions. It is all shown by the listing above. The content of .bash_profile should be ok. – user332331 Jun 12 '14 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.