59

My new server install looks odd: enter image description here

is there anyway to resize it to use the whole terminal window?

  • This madness is finally over! I was cursing those dots where messed up with my highly sophisticate activity, namely copy & paste. – biocyberman May 29 '15 at 13:56
115

This means that there is another ssh or terminal client, other than yourself, connected to this session, which has a smaller window size than yours.

You can detach all clients but yourself, using this Byobu hotkey:

Alt-F6

Or you can run the script /usr/lib/byobu/include/tmux-detach-all-but-current-client

Full disclosure: I am the author and maintainer of Byobu.

| improve this answer | |
  • 2
    I'd upvote you, but I don't have the reputation for it, thank you, it never occurred to me that I'd left myself logged in after I was done setting up the network. – HilarieAK May 30 '14 at 16:09
  • 4
    Alt - F6 did not work for me, but the script does. – biocyberman May 29 '15 at 13:55
  • This shortcut and this command does not work for me... I am using screen and not tmux... – Loenix Jun 23 '15 at 6:00
  • 1
    Some distros may not include that script - you can download it here - raw.githubusercontent.com/dustinkirkland/byobu/master/usr/lib/… – Natalie Adams Jul 2 '15 at 17:40
  • Doing the Alt - F6 on my Macbook Air while Mosh'ing into my server caused me to disconnect as well ;( – dalanmiller Jan 4 '16 at 19:04
7

An alternative to Alt-F6 is Prefix-Shift-D, where Prefix is your byobu escape command (typically Ctrl-a).

See more info here: https://stackoverflow.com/questions/22138211/how-do-i-disconnect-all-other-users-in-tmux.

| improve this answer | |
6

Alt-F6 did not work for me. But I found that I was using tmux. To detach the other window use a combination of list-clients and detach-client:

% tmux list-clients
/dev/pts/1: 0 [64x160 xterm] (utf8)
/dev/pts/39: 0 [39x143 xterm] (utf8)
% tmux detach-client -t /dev/pts/39

Since the 64x160 is larger, I figured that was my window while the other client was the smaller one.

| improve this answer | |
  • This works like a charm. Tried the accepted one and didn't work, but this one did. Good job. – Drubio Nov 27 '18 at 15:29
  • This seems to do the exact same thing as /usr/lib/byobu/include/tmux-detach-all-but-current-client. For me the smaller client "disappears for maybe 3 seconds, then comes back. What gives? – Roger Sep 20 at 14:48
3

Fantastic script! On OSX using byobu installed with Homebrew, it's (currently)

/usr/local/Cellar/byobu/5.92/lib/byobu/include/tmux-detach-all-but-current-client

presumably you'd modify the version number, but that's to give you an idea of how to find it

brew info byobu will tell you where byobu stores its lib etc files.

then just append the lib/byobu/include/tmux-detach-all-but-current-client to whatever that location is (in my case, /usr/local/Cellar/byobu/5.92/)

| improve this answer | |
0

I tried both the script (tmux-detach-all-but-current-client) and alt-F6. None of them worked. The terminal only went fullscreen for a couple of seconds, then it went back to small size (like in the image in the original post). I also checked users with w, it was only me logged in.

What ended up working for me, was simply disabling Byobu and enabling Byobu again, with a logout/in in between. Like so:

byobu-disable
exit
Login again
byobu-enable

Screen is back to normal.

| improve this answer | |
-2

I got it to work sending the command via vim Sepcial chars on your preference keys on iterm2 \033[17;3~

here is image that show the configuration

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.