5

I've just upgraded my whole network to 802.11ac - new router as well as new 802.11ac USB sticks for every computer that doesn't support it out of the box.

For some reason my read and write speeds are horrible, I have 2 PC's setup next to each other with the router not more than 3 meters away (clear sight, no walls).

On both PC's the Wireless connection status shows me a speed of 450+ Mbps, yet if I copy one file to the other I'm getting a maximum transfer rate of 5MB/s

To eliminate the possibility that the USB sticks are the culprit here, I did run the same test from iMac to MacBookPro both supporting 802.11ac out of the box (Both devices approx. 3 meters away from the router, no walls either)

The connection's stats:

  • PHY Mode: 802.11ac
  • 5GHz
  • Transmit Rate: 527

The outcome:

  • Writing: 9.84 Mbit/s - 1.2MB/s
  • Reading: 65 Mbit/s - 8MB/s

I think I have tried every possible settings in the router, I have completely disabled a/b/g/n, tried changing the MHz - updated to latest firmware, all to no avail.

The router model is a D-Link DIR-820L

4
  • Is it possible the router is overheating? This can happen if ventilation is blocked. Does anything improve if you turn it off and leave if for a while before turning it back on? Also, most routers have a WiFi status page that shows signal level, SNR etc. - what does it say? – James P May 29 '14 at 15:53
  • Signal is 96%, what is weird in the router status page it says the devices is connected with a rate of 144.5M, while the windows Wireless connection status says 433.5M ? – Fred May 29 '14 at 17:16
  • What model USB sticks? There are many flavors of 802.11ac, from no-faster-than-802.11n, to nearly 7Gbps (although no one's shipping anything better than 1.3Gbps as of this writing), with many many stops in between. Without knowing which 802.11ac flavors your USB sticks are capable of, it's hard to give a good answer. – Spiff May 29 '14 at 18:31
  • @spiff The Sticks are D-Link as welll, model DWA-171 - they are only used on the PC's since the Macs have built-in 802.11ac – Fred May 29 '14 at 20:12
1

It may very well turn out that the D-Link DIR-820L has a crappy 802.11ac AP implementation. Most 802.11ac APs are top-of-the-line, flagship devices for around $180, that hit the 1300Mbps data rate, which requires:

  • 3 spatial streams
  • VHT80 (80MHz-wide channels)
  • MCS 9 (256-QAM)
  • short guard intervals (SGI)

Slightly less expensive ones only hit the 867Mbps data rate, which requires all of the above except just 2 spatial streams instead of 3.

This device only does a 650Mbps data rate, which probably means that not only does it not do 3 spatial stream, it also doesn't do MCS 8 or 9 (256-QAM).

Note that I'm only talking about the 5GHz 802.11ac performance by itself, I'm not falling for the marking BS where they add their 2.4GHz 802.11n performance to their 5GHz 802.11ac performance.

Anyway, the fact that they can't do 3 spatial streams and can't do 256-QAM is a sign that they made some deep compromises to hit that $75 price. I also note that it only has 100Mbps, not Gigabit, Ethernet LAN ports. Further evidence of corner-cutting that hurts performance.


To really see what that AP is capable of, you need to do a performance test that eliminates the overhead of disk I/O and remote filesystem protocols like SMB and AFP.

I usually recommend that one endpoint of your performance test be on a wired Ethernet LAN port of the AP, but since this AP's wired Ethernet isn't Gigabit, that'll be the bottleneck. The best you could possibly do is 94 Mbps = 11 MiBytes/sec.

So to see something better than 11MiB/sec, you have to do a wireless-to-wireless test, but that will cut your Wi-Fi performance in half.

So anyway, associate your 802.11ac iMac and 802.11ac retina MacBook Pro to the 5GHz network, and run IPerf on each. Make the iMac the IPerf server, and make the retina MacBook Pro the IPerf client. On both ends, add the -w 2M option to the IPerf command-line so that you have a nice big TCP window to work with.

Make sure all three devices are at least 2m apart from each other so they aren't saturating each others' receivers.

If all goes well, and they're all able to sustain the 650Mbps signaling rate that your AP tops out at, I'd expect you to see a max throughput of 260Mbps, which is 31MiB/sec.

The calculation goes like this:

  1. Take the signaling rate (PHY rate) the devices are able to sustain.
  2. Divide it in half since both devices are sharing the wireless medium and the AP is having to do Intra-BSS Relay, which means every packets is sent across the channel twice; once from the source device to the AP, and then again from the AP to the destination device.
  3. Take 80% of that (i.e. multiply it by 0.8) to account for Wi-Fi overhead, assuming frame aggregation (A-MPDU).

So (650/2)*0.8 = 260Mbps. 260/8.4 = 31MiB/sec (8.4 is to convert from 10^6 bits to 2^20 Bytes).

21
  • Thanks for your very extensive answer, I would have loved to buy another 802.11ac AP unfortunately that was the only one I could find going through about 10 shops (I live in Thailand). I will run the test you suggested and report back. – Fred May 29 '14 at 20:00
  • The Result of iperf: ------------------------------------------------------------ Client connecting to 192.168.0.103, TCP port 5001 TCP window size: 2.00 MByte (WARNING: requested 2.00 MByte) ------------------------------------------------------------ [ 4] local 192.168.0.102 port 62896 connected with 192.168.0.103 port 5001 [ ID] Interval Transfer Bandwidth [ 4] 0.0-10.0 sec 60.5 MBytes 50.7 Mbits/sec – Fred May 29 '14 at 20:06
  • So that's atleast 200Mbps less than what I should be getting ? – Fred May 29 '14 at 20:09
  • @Fred It looks like you can buy an 802.11ac AirPort Extreme on the Thai version of the online Apple Store: store.apple.com/th/product/ME918TH/A/airport-extreme . – Spiff May 29 '14 at 20:53
  • @Fred Yes, it looks like you're getting 200Mbps less than you should be getting. Can you make sure your D-Link AP's 5GHz radio is configured for 80MHz-wide channels? If you option-click on the Wi-Fi Menu Extra in OS X, what additional diagnostic info do you see in grey text? It would be nice to know your transmit rate, MCS index, and channel. – Spiff May 29 '14 at 20:57
0

My win7 box was reporting that my AC 5ghz connection was providing only a ~100 (or maybe 175) connection. I opened the router GUI and changed the 5ghz bandwidth from automatic (20/40/80) to 80 and my connection went up to 300Mbps.

Windows may not be reporting accurately but, I know I feel better with 300 being reported as a connection speed over a 100 something speed.

In Windows7 - Click the WIFI Icon in the systray. Right-click the connection name that you're on. Choose STATUS and locate SPEED.

-1

It may be the USB drivers that is causing the problem. Until recently there was a bug in OSX Mavericks that caused 802.11ac file transfers to slow down. Try updating any of the usb drivers on the PCs. Also different protocols tend to get different speeds. Try using AFP or FTP but avoid SMB

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.