25

I am trying to run the command sudo mount -t vboxsf SharedUbuntuWindows SharedUbuntuWindows but I get the error unknown filesystem type 'vboxsf' on my guest Ubuntu machine. I am following these instructions but I cannot find 'Install Guest Additions' under 'Devices'. Instead, I see 'Insert Guest Additions CD image'. Am I even on the proper path to solve the issue?

Screenshot menu

This is what I see when I select 'Insert Guest Additions CD image...'. Pressing 'Force Unmount' only makes the pop-up dialog disappear, but I still am unable to run the command sudo mount -t vboxsf SharedUbuntuWindows SharedUbuntuWindows. Screenshot error message

18

Insert Guest Additions CD Image is the same thing as Install Guest Additions in a different version of Virtual Box. That is the correct menu item. When you choose it, it will be as if you inserted an installation CD to your virtual machine. Run the appropriate setup program from the virtual CD drive.

Guest additions should include the software you need to use the vboxfs filesystem type.

EDIT: Based on your updated question, the real cause error you are seeing is VERR_PDM_MEDIA_LOCKED. Googling for that produces the answer in the first result: http://maheshhika.wordpress.com/2012/09/28/virtual-box-verr_pdm_media_locked/

Essentially, you need to unmount your virtual cd drive before inserting the guest additions cd image. The linked article provides instructions for doing this. Hitting the 'Force Unmount' button would be another way to unmount your drive, and after doing that the insert guest additions cd menu option should work the second time you use it.

Keep in mind that you not only have to insert the virtual cd, but actually run the installer before the vboxfs filesystem type will work.

0
26

All the answer say to go via GUI and "Leave emtpy" the CD drive, but that wasn't working for me: still VERR_PDM_MEDIA_LOCKED error.

In my case I updated my macOS, I was forced to upgrade Virtualbox to 5.2 (I installed without uninstalling first). And now I get reported (by vbguest plugin ) that I need an updated version of GuestAdditions.

The plugin wasn't able to update it. Every reload was always finding the old one (5.1; installed on VirtualBox 5.1).

I tried all the solution on the net and couldn't make it work via GUI (like all the other answers).

VirtualBox was NOT able to really mount the GuestAdditions.iso image automatically via the "Device -> Insert GuestAdditions CD Image...".

So I did

sudo su
cd /media
mkdir cdrom
mount /dev/cdrom /media/cdrom

Finally I got it mounted! Then just go into the mounted dir (cd cdrom) and exec the installer with sh VBoxLinuxAdditions.run (remember you are root).

And I finally got it mounted without the annoying VERR_PDM_MEDIA_LOCKED error! 👍🏻

[Tags: osx,macbook,mac]

3
  • askubuntu.com/a/22745/397973 – Kamafeather Feb 18 '19 at 15:15
  • 1
    This solution helped me. Initially, I did apt-get install virtualbox-guest-utils in the guest Ubuntu, but it didn't help me. Running VBoxLinuxAdditions.run helped. It looks like virtualbox-guest-utils and VBoxGuestAdditions.iso are not the same thing. – dzieciou May 13 '19 at 14:02
  • That's right. IIRC, virtualbox-guest-utils is a repo with scripts for automatically taking care of mounting the VBoxGuestAdditions.iso image to /cdrom, taking care of differences in interfacing with different operative systems, and running the installer cdrom/VBoxLinuxAdditions.run when it is available. Probably also something more 🙃 Glad it helped you out! – Kamafeather May 14 '19 at 4:02
10

just spent some time trying to fix it. This question is old, but maybe my answer serves someone.

A very easy way that I discovered to fix VERR_PDM_MEDIA_LOCKED for guest additions with a ubuntu guest and windows 10 host is:

  1. Shut down (not save state) your virtualbox
  2. Right-click on your machine in the virtualbox manager -> settings
  3. Click on storage
  4. Right-click on the cd drive and "remove attachment" enter image description here
  5. After removing, click on the little CD symbol next to "Controller: IDE"
  6. Choose "leave empty"

Now you restart your machine and click "devices"->"Insert guest additions" and it works

Cheers.

3

The solution below worked for me:

  • Select "Cancel*"

  • Go to "Devices" menu -> "CD/DVD Devices" -> "Choose a virtual CD/DVD disk file..." -> select "VBoxGuestAdditions.iso" from the Oracle/VirtualBox installation directory.


(*) Clicking on "Force Unmount" had no effect, in my environment.

1

Is there. From console type:

> sudo mount /dev/cdrom /media/cdrom
0

Well I was facing the same problem and the solution was simple that open the virtual machine OS and the after opening it open its display setting and the change the resolution accordingly this will fill the screen in background completely.

Not the answer you're looking for? Browse other questions tagged or ask your own question.