5

I triple booted my Macbook 4,1 with Mac OSX 10.5.8, Lubuntu 14.04 and Windows XP SP3 and installed rEFInd as my bootloader.

Now what basically happens is, first the Mac bootloader loads invisibly, but I know it's there since I can summon it while pressing the option key.

When I choose Mac or Windows it goes straight to the actual loader of that OS, but when I choose Lubuntu it opens the grub bootloader first, giving me the same options. I have set the grub bootloader, to load lubuntu after 1 second, so it doesn't stay there for long time, but how can I just skip grub, like Mac and Windows are doing?

Three loaders (Mac, refind, grub) slows down the boot quite a lot, especially since most of the times I just want to boot to the default OS anyway, so how do I reduce this time? Or is there a reason why I should leave it as it is?

1 Answer 1

1

There is a distinction between a boot manager and boot loader.

From the official website of rEFInd:

rEFInd is a boot manager, meaning that it presents a menu of options to the user when the computer first starts up [...]. rEFInd is not a boot loader, which is a program that loads an OS kernel and hands off control to it.

but GRUB is both:

Many popular boot managers, such as the Grand Unified Bootloader (GRUB), are also boot loaders, which can blur the distinction in many users' minds.

If you want to remove the timeout in the GRUB boot menu you can edit /etc/default/grub and set

GRUB_TIMEOUT=-1

You then have to do

sudo update-grub

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .