0

Final update : I did sudo yum update as per @Andre's suggestion, which on my crummy internet speed took a while but fixed everything. If yum reports it needs to download X MB it usually ends up downloading less in the end.


Update: So I'm able to log into a virtual terminal (by pressing Ctrl + Alt + F2). I can fortunately access my data and even connect to the internet from the CLI. But I really really want to get my system running, I've done a ton of configuration and installations on this system.

I can give you guys any info you want on the system.


Update 2: So I found out from journalctl -b -1 that there was some GPU problem:

Jun 04 17:07:01 gideon-fedora kernel: [drm] stuck on render ring
Jun 04 17:07:01 gideon-fedora kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
Jun 04 17:07:01 gideon-fedora kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Jun 04 17:07:01 gideon-fedora kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Jun 04 17:07:01 gideon-fedora kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Jun 04 17:07:01 gideon-fedora kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Jun 04 17:07:07 gideon-fedora kernel: [drm] stuck on render ring
Jun 04 17:07:07 gideon-fedora kernel: [drm:i915_context_is_banned] *ERROR* context hanging too fast, declaring banned!

BUT, what do I do to get everything back up? This bug cropped out of nowhere, and while I will file a bug report, what do I do? Note that I can boot into Windows 8


Update 3: So booting with nomodeset gets me a low res boot screen and my desktop shows up fine.


So like I said, my Fedora 20 is busted.

I have a system with Fedora 20 and Windows 8 on it. On my fedora I've been kernel hacking and I have several kernels built and installed. See Screen shot of my boot-screen:

https://drive.google.com/file/d/0ByTMphxFKJxjTF93UEx0UFVMNTl0V0JNRXJlUW9EY2o5TXZR/edit?usp=sharing

When I choose ANY of the kernels installed in Grub OR the Fedora with 0-rescue, it loads up for a bit, the fedora logo shows up, once the icon is in full color (loaded) the screen turns black and the backlight is on! I can boot into my Windows 8 which runs fine.

Here is what I get when I boot without rhgb and quiet and with debug:

https://www.dropbox.com/s/gyz1sbllyqhuz10/Photo%2031-05-14%2012%2056%2038%20am.jpg

I booted into the LIVE CD and that is where I am right now, I don't see any repair or re-install option. When I say install to harddrive from the live CD it cribs about no space and doesn't give me options to repair my existing install.

Please help! I have tons of data and projects I'm working on! :( All on this fedora install. I would really like not to wipe the whole thing off, but I really want my home directory data.

  • Have you booted without the rhgb and quiet parameters? You could also boot with the debug parameter. – Cristian Ciupitu May 30 '14 at 17:23
  • Here is picture of the boot screen : dropbox.com/s/gyz1sbllyqhuz10/… – gideon May 30 '14 at 19:44
  • @CristianCiupitu I can log into the system from a virtual terminal. Everything seems to work except the gui (I can connect to the network). – gideon Jun 2 '14 at 11:12
  • 1
    Try updating the system (using yum), it might just be a bug introduced with the last update that is already fixed in the latest version. – user256743 Jun 6 '14 at 10:08
  • @André Thanks for the comment :) you mean do a system-wide update of all packages? How would I do this with yum? Note the third update in the question. – gideon Jun 6 '14 at 10:59
1
+50

Solved in the comments; updating the system with yum update solved the issue - it looks like it was caused by a bug/regression introduced in a previous update that is now fixed by the latest update.

  • thanks very much. Good call posting an answer, I was going to tell you to do that. – gideon Jun 8 '14 at 16:42
2

Hmmmm.....I hope that with "tons of data and projects" you have make appropriate backups. I find it amazing that you are hacking a kernel on a system containing critical information.

If you can use the rescue disk to mount the partition and move the data off to another source ASAP. Then you can try recovery operations.

Be prepared for the fact that you may have to reinstall everything and restore your projects from backup.

  • Thanks for your answer. I have a live CD and the 0-rescue item on my boot list also hangs up after the loading icon is done. Or do you mean something else when you said rescue disk ? – gideon May 30 '14 at 19:06
  • sis you see the updates on my question ? – gideon May 31 '14 at 4:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.