0

My computer is a year old desk top running windows 8.1. A few weeks ago I was typing a message and just as I was hitting enter a dialogue box flashed on the screen but before I realized it and read it I had already selected something and my keyboard promptly stopped working. Pressing the keys caused it to beep but not type. on restart it worked for my login but beeped after that. device manager said it was functioning properly so I looked in ease of access and toggled off sticky and filter keys, uninstalled and reinstalled the keyboard, tried another keyboard , bought a new one, used system restore and now half of the keys work- I made sure it was set to US English and still only half the keys work. some keys bring up right click menu. I've also tried holding down the shift keys. any suggestions?

  • It's always a good idea to create a second account on the box (with admin privileges) for this sort of thing. Likely whatever it was was some stupid Windows mode setting on a per-user basis, and the second account would have allowed you to see if this was the case and at least access your data. – Daniel R Hicks Jun 7 '14 at 11:40
1

Does it work with another computer? do you have access to a linux bootable live disc? they work wonders to troubleshoot hardware related issues (if it works on other OS on the same machine then it's a software issue, if it doesn't then it's a hardware issue). I need more information about the state of the supposedly faulty keyboard.

Also, chances are that you got some annoying malware there, run a check using adwcleaner it's freeware and portable.

Good luck.

  • after a frustrating live chat with a moronic windows rep who insisted I had to fiddle with the BIOS before telling me my support had run out- apparently she didn't like that I had already trouble shooted it and knew it wasn't a hardware problem nor a serious software issue- the thing had been toggled off, prompted by a windows response box- I finally got it working by holding down keys- not sure now which ones, I mashed a bunch and held them and it started working- I think there is a filter key lock or something. No malware, no BIOS issue, nothing wrong with the hardware, a simple solution – GSPanther Jun 1 '14 at 12:21
  • That sounds strange, I haven't had a similar issue, but I'm glad you were able to solve it. Things like this happen. Good luck. – arielnmz Jun 2 '14 at 7:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.