I had some problems with amarok player, I couldn't get any sound from it. Anyway, I fixed it somehow, from terminal, with some packages, after a couple of reboots, now I have problem with the adobe-flashplugin.

I'm trying this in terminal but:

sudo apt-get install adobe-flashplugin

Reading package lists... Done

Building dependency tree

Reading state information... Done

E: The package adobe-flashplugin needs to be reinstalled, but I can't find an archive for it.

I also tried the update manager, but I get something about partial upgrade but that thing also isnt working, and I get a message that I have to install it manually or I remove it completely.

So, how can I remove it completely and then I will install it clean again from the beggining?

1 Answer 1


after a lot of googling...finally!

$ sudo rm /var/lib/dpkg/info/adobe-flashplugin.prerm # Deletes a troublesome config file

$ sudo dpkg-reconfigure adobe-flashplugin --force # Force-reconfigures adobe-flashplugin

$ sudo dpkg --purge --force-all adobe-flashplugin # Force-removes adobe-flashplugin

$ sudo apt-get install flashplugin-nonfree # Installs flashplayer the easy way

cheers ;)

Not the answer you're looking for? Browse other questions tagged or ask your own question.