My wife's computer has been running Ubuntu 9.04 32-bit, but now she has 6GB of RAM, so I tried upgrading to Ubuntu 9.10 64-bit. She has a AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ and 64-bit Ubuntu will install, but if I try to use rsync to copy files from my computer, her computer locks up immediately. If I don't rsync, the computer takes a few minutes before it locks up. I also tried 64-bit 9.04 and it had the same problem. I ran memtest86 and it says there is no problem with the memory. what else can I do to figure out what is causing the problem?

note: each install was a clean install and i use rsync to restore her files.


Have you checked /var/log/messages for kernel and system logs? It may give insight into what happened leading to the lockup.

The SYSSTAT Utilities are also great for monitoring performance of a Linux box all around. From CPU to memory, Disk I/O and networking. They will help you pinpoint what's causing the random lockup if it is a slow buildup of resource usage.

A complete tutorial on their usage is found here.

| improve this answer | |

Does your Ubuntu system have strace installed? If so, preface your rsync command with strace to see the system calss being made. This is likely to generate a lot of noise but might give you a clue where it's locking up.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.