1

Since few days I have tried to apply this ActiveX to my Excel 2013. I made small app for running reports in Excel and I need some way to pick start and end date.

Easiest way to do it was Date And Time Picker Control which is in %windir%\syswow64\mscomct2.ocx. It worked perfectly at Windows 7 64-bit + Excel 2010 32-bit.

When I moved my project to other PC with Windows 7 64-bit and Office 2013 32-bit it stopped working. Firstly there was class missing, so I registered Microsoft Windows Common Controls 2 6.0 (SP3) in syswow64 using regsvr32.exe command.

It did not help - it was keep saying "cannot insert object". Tried another versions of Common Controls (currently SP6), but problem is still there - I can`t put any control to my Excel worksheet.

I`m running out of ideas and tutorials, so maybe some of You had ran into this type of problem and have solution?

7
  • Does the "other" PC have the same trust and security settings as the PC you move the file from? Did you trust the document after you moved it to that PC? – CharlieRB Jun 3 '14 at 11:41
  • What exactly do You mean by trust and security settings? I performed both actions using Admin account, also both PCs have their Windows Firewall switched off. – Paweł Czech Jun 3 '14 at 11:51
  • Office uses advanced security which requires you trust documents and locations in order to protect your computer. Use the Trust Center to adjust settings. It may be why you are unable to use certain features. – CharlieRB Jun 3 '14 at 12:29
  • I switched all the options to "lower security level" - enabled all, no mather what. Still the same problem is existent. – Paweł Czech Jun 3 '14 at 13:14
  • Try running a repair install to see if it fixes a damaged files or settings. Do this via control panel > programs > uninstall. Choose your Office version, then select "change", not "uninstall". Once it starts you will have an option to "repair". Running this will fix any damaged or corrupted files in the Office Suite. – CharlieRB Jun 3 '14 at 15:08
0

I was getting this same error in Access 2010, but the issue was resolved when I made the folder where the file was located a trusted location. I do not fully understand the fix, but I had to put it out there because there is precious little on this strange error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.