0

I am set up with Xfinity using an Arris TG862G/CT as our modem/router device.

I have set up port forwarding through the router and it mostly works except for two problems.

  1. Reverse proxies with Apache seem to not work (they did previously, until I moved on to my current network). When browsing to the reverse proxy (rp.example.com, which is a proxy for example.com:8081), it gives a 503 Service Unavailable error. But when I browse using the port directly, it works just fine, so I can see that the service is in fact running and is not unavailable.

  2. Secondly, SSH does not work at all. I, again, set up forwarding to forward port 22 to my server. But when I try to log in outside my network, I get either a Host does not exist error (when using my domain name) or a Connection timed out error (when using my ip address). I know for a fact that SSH works though, since I can connect to the server inside my network.

    2.1. NOTE: I am using putty as my client.

Has anybody else had experiences such as these? I have no idea what else I can do to trouble shoot the problem. I have even set the DMZ host to be my server, which did nothing visible.

Thanks in advance!

Bonus: Does anybody know how to enable Hairpin NAT on the router (or simulate it somehow)? I hate having to use my hostname inside the network and the domain name outside. I would rather just use the domain name everywhere.

migrated from serverfault.com Jun 3 '14 at 13:15

This question came from our site for system and network administrators.

0

I too have found the same problem with the same router from Comcast. It seems to be a total piece of junk as when you enable a DMZ host instead the SSH port works fine. When just forwarding the SSH port it fails about 99% of the time (every once in a while it works anyway).

Best bet is getting your provider to put the router into bridge mode and using ANY other router.

--

Actually I just discovered the built in firewall appearently is seperate from forwarded ports. And if not on Custom Security it seems to block port 22 even though it doesn't list that!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.