I have Ubuntu 13.10 x64 installed as a guest in VirtualBox (under a Windows 8.1 host) and have the settings for the virtual machine setup to run with a monitor count of 2, 128MB video memory and 3D acceleration enabled. In my guest I have the virtual box additions installed (which allowed me to have two 1920x1080 screens).

Here's a screenshot of my VM settings:


My laptop is an Asus N550JV which has both Intel's HD Graphics 4600 GPU and Nvidia's GeForce GT 750M. By default though I believe the Intel GFX card is being used to render the VM.

When I boot up the VM it loads perfectly on dual screens, however whenever I move the mouse from one screen to the other (I have a Dell S2340L running over a HDMI connection as a second screen) the screen flickers.

I've tried a variety of settings changes in both Ubuntu and the VM settings, but cannot seem to stop this screen flicker.

I also used the NVidia control panel in Windows to force the dedicated graphics card to always be used but found that the display driver sometimes crashed whilst working in the VM, resulting in my VM session being destroyed, so I figured it's better to stick with the Intel GFX as that appears to be more stable. I also tried without 3D acceleration but that was much worse, and if I ran the VM with a low amount of graphics memory it really struggled.

Here's my dmesg output: http://pastebin.com/1LJuYWMj (not sure if this is helpful in this situation).

I read some posts suggesting changes to /etc/X11/xorg.conf but I don't appear to have an xorg.conf file. There were also a few posts (though related to Synergy) suggesting running xset -dpms but this command doesn't appear to have had any effect for me.

As an additional note, I'm finding that window drawing in the guest is a little laggy/glitchy. For example, quickly scrolling through a web page may result in parts of the viewport displaying original content. Certainly I notice drawing issues most in the web browser, but it also impacts other software with parts of the window not being drawn when, say, switching between accounts in thunderbird.

Any suggestions greatly appreciated!

  • Why downvoted? I'm trying to ask the right questions here on SuperUser but seem to be struggling.. Any guidance appreciated. Jun 11, 2014 at 8:58

4 Answers 4


Actually fixed this by using the nVidia control panel to force virtualbox.exe to always use the integrated Intel graphics.

  • Just to help others: NVIDIA Control Panel > 3D Settings > Manage 3D settings > Program Settings > Add then browse to virtualbox.exe and set Itegrated graphics as the preferred graphics processor for this program.
    – Matthew
    Jul 31, 2015 at 21:15

Did you install the Oracle VM VirtualBox Extension Pack?

I believe you might be able to tweak an Xorg configuration and hopefully solve your issue.

This is no longer an xorg.conf by default. Instead it auto-detects the settings by default. So, rather than copy a xorg.conf from an online resource, I suggest you get your system to create one for you.

To do so, you will need to run

# X -configure

If you do this while you are using your WM, you will get an error like this.

Fatal server error: Server is already active for display 0

You have 2 options.

  1. Boot to Linux recovery mode (it's an option in your bootloader) and run the above command.
  2. Press Ctrl+Alt+F1 and gracefully shutdown your window manager and run the above command.

Once you have run X -configure. Copy the new xorg.conf to /etc/X11/. The new xorg.conf will be in /root/ because you booted to recovery mode and were root.

dmesg is ok, but showing the output of lspci would also be helpful.

  • Thanks for all this information which I'll definitely play around with. Turned out I just needed to make sure VirtualBox didn't use the nVidia graphics card. Jun 11, 2014 at 9:01

I had the same issue, but on a desktop computer. Seems like there is no setting avaliable in the Nvidia driver to force using the integrated GPU, which should be possible, since I have a Intel i5 CPU with an integrated graphic card. I also tried different settings in the 3D settings of the Nvidia driver, nothing worked.

But I figured out, that this is caused by the 3D acceleration of VirtualBox: On the screen showing in the first post of this thread (VM-Settings > Display), disable 3D-Acceleration, and check 2D-Video-Acceleration instead.

My tests doesn't show a difference from 3D to 2D. I think, this would only have impact if you're using graphic-intensive applications like games. But if you use the VM for working purpose like software-development in my case, it looks like a quick, working fix to get ride of the flickering.


I had a similar issue and found another fix. My setup:


  • Win 10, 64bit
  • 2x 24" screens running @ 1920x1080
  • Intel i5


  • Linux Mint 18, Cinnamon
  • 3D hardware acceleration on
  • Screens running @ 1920x975

Due to an unrelated matter, I wanted to increase the guest resolution to the more common 1920x1080. After doing so, the flickering began. The flickering only happens when one does certain actions such as right-clicking to open the context menu, or doing a drag selection on the desktop. So it seems related to graphical processing or the desktop manager (Cinnamon).

I followed the suggestions here and turned off 3D acceleration. This worked in that the flickering was gone, but caused the system to slow down somewhat, presumably because it had to use software rendering which is CPU intensive.

I set the guest resolution back to 1920x975, turned off the guest, enabled 3D acceleration again, and started the guest again. The flickering stayed gone.

So, if you have flickering, consider trying some other resolutions to see if this works for you.

The slightly lower vertical resolution is actually quite helpful because it allows having the virtual computer in full windowed (not full screen) mode without having a vertical scroll bar. This is useful if you often switch between host and guest as I do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.