1

I am using a Korean software (with a partial English interface) in a Korean Version of Windows XP SP 3
However, in parts of the software, even when I change the interface to Korean, Korean letters show up as random characters, as shown here:

enter image description here

This is happening at others parts of the software as well, and I am not sure what is the difference between the places where this is happening, and places where this is not happening. For example, a command button where Korean letters are showing up properly is shown below:

enter image description here

This software is a video conferencing software and has a chat feature as well. When I type into the chat box, i can see the Korean letters appear properly at my side, but when I press Enter and send the message, it changes into random characters as shown above in the chat box.

What could be the issue here? Could it be a missing font in my computer? Since this is a Korean Windows installation I was hoping everything would work properly by default. What can be done here?

EDIT 1:

I asked some other people who are using this software, and they think that the problem is at my end, and playing around with the Regional and Language Settings might solve the problem. Also, they suggested I install all the language packs related to Korean display. But it looks like all the language packs have been installed, and my location is set to Korea in Regional and Language Settings in Control Panel, and I still have this problem.

Also, I have had similar problems with displaying Korean on an English Windows XP computer. This answer suggested some solutions, but I still do not quite understand exactly what I have to do (at that time I had not fixed the problem, as I later on changed the computer). If I follow that answer, what fonts exactly do I need to install?

1

Try setting the system locale for programs that don't support Unicode.

To do this, search for and open intl.cpl to launch the "Region" control panel options dialog.

Select the Administrative tab, and in the lower section "Language for non-Unicode programs", set it to Korean (Korea).

Windows Region Control Panel Dialog

I had a similar issue and the answer there should be applicable to this question.

| improve this answer | |
  • If you believe this to be a duplicate of an existing question why did you not flag this as a duplicate of that question? – Ramhound Oct 2 '19 at 17:21
  • It's similar but not duplicate -- and I asked the other question that got an answer in 24 hours... so there seems to have been a qualitative difference. Doesn't matter to me which is the canonical question - but if both exist, might as well have both get answers. – JohanTux Oct 3 '19 at 1:56
  • 1
    I think the difference might have been that I did not see this question when it was originally asked ;) – Bob Oct 3 '19 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.