0

I've got a Toshiba laptop acting strange on me. Any thoughts appreciated.

C850-11C PSCC2E AMD E1-1200 APU Windows 8 UEFI

Problem: Laptop cant restart. If i shut down the OS or restart, or it restarts it self becaus of an installation or update, it cannot boot up. Display turns on, its blank but illuminated (purple not black). Stay that way for a couple second then restarts. It doesnt even get to the Toshiba leading innovation logo. Cant get into BIOS or recovery either. (F2 or F12) Only way it starts is if i unplug, remove battery, hold down power for 30sec then plug in and start it. In that case it boot perfectly. But no other way.

  • Tried resetting bios setting to default.
  • Tried Windows reset, refresh.
  • Tried removing the bios battery.
  • Tried removing HDD , but i dont think it even gets to the point of accessing devices.

Same thing if plugged in/on battery/ both.

Im thinking it might be some kind of internal power component problem....maybe? Any thoughts welcome!

UPDATE: Turns out, CMOS reset is not the only way. Unplugging power (no battery) and pulling RAM module, than putting back results in successful boot too.

  • Have you replaced the CMOS battery? You say you removed it but that only resets the stored configuration which doesn't really help. – Ramhound Jun 4 '14 at 16:22
  • no, put the same one back in. Multimeter showed 3.05V so i thought its good. – Losó Adam Jun 4 '14 at 16:29
  • If you remove the battery, drain the power and it boots fine, what do you do that causes it to fail again? – arielnmz Jun 4 '14 at 16:40
  • I would replace the battery, purchase it from a store, so you can take it back if nothing changes. – Ramhound Jun 4 '14 at 16:48
  • Does it behave the same way if you boot into, and then shutdown another OS (say a Linux LiveCD)? What if you do a "Clean Boot" into Windows, does it still behave the same way? – Ƭᴇcʜιᴇ007 Jun 4 '14 at 16:52
0

At this point I would try and run memtest 86++. Failing memory has been know to cause all kinds of crazy issues and killing POST is definitely one of them.

  • was thinking the same, so put in another known to be good module, same results – Losó Adam Jun 4 '14 at 18:55
  • It could be the the DIMM bus on the board. I would still run memtest 86++ which should reveal a failing DIMM too. If you have reports of failed memory, and your memory is known to be good, you have a bad mainboard. – Scott James Walter Jun 4 '14 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.