I'm having a bit of a problem with using three monitors with VMWare Workstation 10. When only two monitors are enabled in the system I have an option to "Cycle Multiple Monitors", available from the View menu (in full screen). When I enable the third monitor that option is no longer in the menu and I can only use one monitor at a time. I've found this article and a "Choose a Monitor Layout" button is mentioned there but I'm unable to see it anywhere.

I'm using Windows 8.1 as the host and Ubuntu 14.04 as the guest. The graphics card is AMD Radeon R9 290x with latest beta drivers

  • 1
    I do have the same problem with VMWare Workstation 11 and Debian 8. With two monitors "Cycle Multiple Monitors" is available but not with three. Jan 19, 2016 at 13:05

4 Answers 4


Make sure your VMs are configured properly for multiple monitors:


  • As far as I can tell the VM is configured to use multiple monitors since I have no problem when using two displays. The issue is with using all three monitors.
    – whtvr
    Jun 4, 2014 at 21:51
  • Some X Server configurations come with support for two monitors. I would try to find how the displays are configured for two monitors and then verify that information for three monitors exists. I remember researching this but not the details of what I found.
    – PatS
    Mar 30, 2019 at 15:32


The use of more than two monitors two monitors with a virtual machine has certain limitations

So i wouldn't be surprised if you ran into any problems.

I think one solution would be to connect them all properly into ubuntu and then do that VVV using the catalyst control center. https://linuxacademy.com/blog/linux/ubuntu-and-multiple-monitors-amd-edition/

Could you elaborate on what you mean by using one monitor at a time? Like with examples or pictures

  • What I meant by using one monitor at a time is that I can move the VM window to any monitor and switch it to full screen. The problem is that it's not possible to make the VM use more than one monitor. I'm not sure that the problem is with the guest OS - as mentioned in my original question, I'm able to use the "Cycle Multiple Monitors" feature when only two out of three monitors are enabled in the host's display driver but not when all the desktop is extended to all three screens.
    – whtvr
    Jun 4, 2014 at 21:46

I had a similar problem on Ubuntu 14.04/16.04. The "Cycle Multiple Monitors" option is not available in the View menu, but the button is available in the Toolbar and is usable.

Note that right now this feature only works properly on Ubuntu 16.04 when 3.19 kernel is used: https://github.com/vmware/open-vm-tools/issues/74


It's working with the later patch versions of the 4.4 kernel - upgrade your distro first and reboot - it should work fine:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Also make sure that in VmWare edit.. preferences.. Display you have selected "Autofit guest"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .