1

At work we have an WinSBS domain at the heart of our network, which is all Windows PCs. The domain controller is acting as a DNS for these computers.

I have recently added some personal use Linux machines to the network, without joining them to the domain. I have set up Samba with "wins server" pointing to the domain controller, which lets the Windows boxes resolve the Linux hostnames just fine.

I also have resolvconf set up with the domain controller as a nameserver and the local domain as a searched domain, which lets the Linux boxes resolve the Windows hostnames just fine.

However, the Linux boxes will not resolve other Linux hostnames at all. Given that I don't have control over the DNS server (I am not the network admin) and that at least one of the Linux boxes is not an always-on machine and is likely to change its LAN IP frequently (via DHCP), what service am I missing to make their hostnames visible to each other?

edit:

Just installed smbclient so I could list hostnames from the domain controller, all of the Linux boxes are showing up (I guess that should be expected since I can ping them from Windows). I can also use nmblookup to resolve a Linux hostname through the WINS server. I have also edited /etc/nsswitch.conf to add the 'wins' parameter to the 'hosts' option. Still, cannot resolve Linux hostnames through nslookup/host/dig.

0

The Linux boxes aren't registering their DNS names with the Windows server. (Other Windows boxes trying to reach your Linux boxes are failing DNS and falling back to WINS lookups, which is why they still work anyway.)

Try both answers from Register A records for my Linux box on my Windows 2008 DNS/DHCP server (Server Fault).

Or, if you want a more locked down approach, read Linux DHCP and Windows DNS.

| improve this answer | |
  • All of those solutions require access to the domain server, which I don't have. WINS resolution is fine for me, now I'm trying to get generic hostname resolution using WINS (nsswitch "hosts = wins" isn't working) – James Jun 4 '14 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.