I know this is a pretty common question but I did my research and couldn't find a solution for this issue. I'm configuring a development application server and I came to the point where I can ping both localhost and, but I cannot browse either of them from IE or Firefox. I can browse and ping other websites (such as google) just fine.

I tried flushing the dns (ipconfig /flushdns), restarting the IIS Admin service, restarting IIS itself, etc, and nothing seems to work. The results from ipconfig /all shows IP Rounting Enabled = No and WINS Proxy Enabled = No. Hwat is intriguing to me is that I compared everything in IIS in the dev environment with the production environment and the settings are the same, but I can browse localhost in production, but not in dev!

What could be causing the inability to browse localhost and from IE and Firefox?

  • what if you browse to your local IP (not localhost) – Keltari Jun 4 '14 at 22:32
  • when you say can't browse, what do you mean? like can't browse a local web server? or can't do start \\ip or can't browse the web like google? – barlop Jun 4 '14 at 22:38
  • Is your dev server configured on port 80, and is port 80 open? – Pockets Jun 5 '14 at 0:13
  • @Keltari: Browsing my local IP give the same result - HTTP Error 404 (but, again, pinging the IP works). – Anna Jun 5 '14 at 15:54
  • @barlop: what I mean is that if I open my browser (IE or Firefox) and type either localhost or my IP address and search, I will receive an HTTP error 404 - Not found. But if I use the browser for anything else (Google, email, etc), it's working (which means the problem is not with the browser itself). – Anna Jun 5 '14 at 15:57

Try this: Reset TCP/IP and Winsock > right-click Command Prompt, and then click Run as administrator. enter this command:

netsh int ip reset c:\resetlog.txt

Restart the computer.

If that does not work try this command:

netsh winsock reset catalog

  • I ran the command netsh int ip reset c:\resetlog.txt and restarted the machine, but now I can't login to the machine again :S – Anna Jun 5 '14 at 16:30
  • It turns out that when I ran netsh int ip reset c:\resetlog.txt, the machine lost its IP address and I couldn't login. I had to ask a team member to fix that for me, and once I could log back in, nothing had changed: still same error when I try to browse. – Anna Jun 5 '14 at 16:41
  • I tried the second command, netsh winsock reset catalog, and it didn't work either. – Anna Jun 5 '14 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.