15

I have a Lenovo ThinkPad S430 with an Intel 4000, 7 series chipset. This is running Windows 8.1 Pro 64-bit.

My USB ports began to have trouble recognising when I connected devices around a month or so ago. I would pull out the device and re-connect, perhaps in a different port and try again and it would work. Over time though this became more unreliable until I would re-connect maybe five or six times until it worked. I attempted to re-install the drivers through Device Manager but now no USB devices will connect through any of the ports.

Devices do not appear under their usual, respective section in the Device Manager (e.g. Keyboards under the keyboards category), instead they all appear under the 'Universal Serial Bus Controllers' as an unknown device.

Windows 8 apparently has extra information beyond the typical code 43 and in this case it states: "A USB port reset request has failed".

I could not find any further information on what this mean exactly although I am a little concerned that maybe it is a serious hardware problem.

I have tried re-installing drivers from both Intel and the Lenovo site for USB 3 and the Intel chipset but neither have worked. Moreover it is not clear that the drivers have installed correctly.


UPDATE:

I found that disabling USB 3.0 in the BIOS fixes the problem although now I don't have USB 3.0 support. I did install the USB drivers from Lenovo, and forced the install with compatability mode - apparently though USB 3.0 support is included with Windows 8.1. I have uninstalled the drivers but the problems remain.

What can I do to ensure the Windows 8.1 USB drivers are used and the the Intel ones have been properly removed?


  • Did you solve this eventually? – Paul Oct 23 '14 at 14:58
  • 1
    I think so. Uninstalling the third party drivers (i.e. Intel) seemed to work, USB 3.0 devices no longer appear as separate devices in the Device Manager and the native Windows 8.1 drivers seem to work just fine. I think the problem is that I had drivers from when I had Windows 7, then when I upgraded to 8.1 the drivers were no longer compatible and caused problems ... – Brendan Oct 24 '14 at 9:02
  • Thanks! Here's what I have: i.snag.gy/IIT2K.jpg. Do you remember which one is the problematic one? – Paul Oct 24 '14 at 15:00
  • Hmm none of those options look familiar or likely. You might have to go into Device Manager (Windows + X -> Device Manager) and select USB 3 device hub (or similar) properties and uninstall the drivers from there rather than the Add Remove Programs dialogue ... – Brendan Oct 26 '14 at 17:54
  • 3
    If you solved the problem, please answer your own question and mark your answer as correct to close the issue. If the issue persists, just upgrade to Win10. – HackSlash Jun 8 '18 at 20:03
1

It appears to me that you may well be attempting to insert USBv2 devices into USBv3 ports, and that your version/copy of Windows doesn't gracefully throttle (down) the port.

If I were you. I'd discover which of your ports are version 2 vs. version 3, and plug slower devices into the version 2 ports, and faster into the version 3 ports.

| improve this answer | |
  • Intermixing USB2 and USB3 devices on the same port often produce strange behaviors. – Claude Frantz May 18 at 14:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.