Here is a video about how my requests are queued up in Chrome and how much time it takes.

It is amazingly slow:

  • More than 3s just for a DNS lookup
  • Around 20-30 seconds to load a page and also fails some files
  • Many requests are in "connecting" mode for a long long time
  • In resource panel you can see that chrome has more than 100 tcp connections

About my config:

  • Win 8.1
  • Wire connection
  • No app running, just that browser
  • 12 Mbps internet, as you can see in the speed test

What I've done:

  • Read some posts about this topic, but nothing works
  • Changed DNS to the Google ones
  • Talk to the free assistance from my internet provider and told me to call the paid assistance
  • Wireshark packet capture but I'm not a pro understanding what is going on but I have a lot of balck lines and some red ones lol

What I'm asking:

  • I would like to know what should I do before I should pay for internet service. They charge money if I call them, and is not cheap.
  • Any fix about this problem
  • Maybe tell me what is really going on. I know that bandwidth != throughput, so yes, I can download big files fast (1.4MB) but for small bits like in games or websites everything is slow.


  • I have this same issue when using a VPN. It's fine on other machines, and fine without the VPN. Connect to the VPN and the symptoms you describe appear. I have yet to find a solution, did you? I think it might be related to the way Windows routes packets to hosts. It tries one interface first, and if that times out tries another. Thus the initial connection takes ages, times out and then works quickly as Windows knows to route to the correct interface. – user237698 Jan 12 '16 at 8:51
  • Does any other web browser, or pinging different "new" servers in a terminal go faster? If you're connecting through a router do things go better when connected directly to the modem / internet? – Xen2050 Jan 24 '16 at 13:24
  • Keep in mind this could be your router. Sometimes they get disgruntled and blank out every few seconds. Try plugging in an ethernet cable and see what changes. – Spencer4134 Jan 29 '16 at 3:21
  • Did you try changing your DNS to OpenDNS and see if that helped? Also if it is ok with you install NetBalancer. It will let you know if any particular software is hogging your connection. – Ganesh R. Jan 29 '16 at 19:12

From the speed test you ran, you have a mere 1Mbps of uplink speed. Your ping time to the local server was 23ms, which is okay. I can also see in your taskbar/tray, that you're running uTorrent.

If you're torrenting, you're losing a lot of your uplink speed. In other words, your requests are fighting to get out to the DNS server and the other webserver amongst all the Torrent traffic.

Try throttling your Torrent uplink speed to 500 kbps by changing your uTorrent settings. (approx 1/2 of your 1Mbps uplink speed.) And see what happens. I suspect this is your problem.

EDIT 1: Your issue is symptomatic of high latency issues. You can trying pinging various servers at the Windows command line using the "ping" command. I can ping Google and Bing and get sub 5ms responses. Maybe you need to look for a closer DNS server. I googled https://www.google.com/search?q=dns+portugal+servers and manually enter a DNS server until you find a few with really low ping times.

  • 1
    Well, when utorrent is running, no page loads at all, I'm already used to it. I will try your fix. But the problem is not utorrent, which is not running or is idle at the time of the speed test. The problem still persists. – Totty.js Jun 6 '14 at 8:45
  • I added more suggestions... – Pretzel Jun 6 '14 at 16:59
  • Thanks with my current settings I have 25ms ping for google.com I will try another DNS, if the page loads today. The internet at night is really really worse, more than 1 minute to load a page and fails everything. – Totty.js Jun 7 '14 at 2:30
  • You might want check your connection quality here – Vinayak Jun 8 '14 at 15:01

looks like old post, but since I don't see concrete discussions and solutions, here is one attempt from me.

First, let me say that your explanation of the problem is exactly as if I had described what I am experiencing. Tried number of times to address it, but had no luck in solving it. I was suspecting the quality of my provider's network, but no conclusion on it at all. Mind you - I have very good nominal speed and speedtest and pingtest often confirm this.

Now, to the point: This is what I just found by chance:

Start Chrome using "no sandbox" switch, as in

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --no-sandbox

Tried, and at first glance, it looks like it improved (even fixed) the issue. But I'll have to see over the next day or two how it behaves.

Found it here:


Edit: The video shows exactly the adding of the switch to the Chrome shortcut in Windows. Most likely no need to watch it, but there it is for the reference anyway.

Edit 2: Note that after adding this switch the Chrome will show you warning message about "unsupported switch, stability and security will suffer". I don't know much about security implications, but I am guessing this may reduce protection in some way.

  • Please summarize the video you linked to—videos can be deleted and not everyone is going to spend the time to watch it. – bwDraco Feb 2 '15 at 19:48
  • Thanks for the note DragonLord - I added the summary paragraph to my response. – milan Feb 2 '15 at 20:02
  • Appreciate your responding to this question. Super User's purpose is to build a knowledgebase, so it's important that answers be definitive. Your experience looks like this answer is still tentative. After you have a few days with it, can you update your answer accordingly? Thanks. – fixer1234 Feb 2 '15 at 20:46
  • Thanks for the reply. Since the question I've moved to Vodafone and I can confirm that my previous network provider was really bad! IMO no tweak would resolve it. – Totty.js Feb 3 '15 at 0:53
  • Yeah, the "no sandbox" switch definitely helped. It didn't really "fix" the issue, but I could say it did fix it in, say, 80% of cases. – milan Feb 5 '15 at 7:06

Try to disable IPv6 if enabled, and check if yout hosts file is not too heavy (it slows down resolves).

EDIT 1 : uTorrent creates many connection that your router may not handle and it may become slow until a reboot (it already happened to me with a cheap low cost ISP gateway). Does it work better after a reboot ?

You can download lot of data faster than some bytes due to TCP protocol which is slow to etablish a connection each times.


The newer versions of uTorrent tend to "take over" an internet connection, even when not in use (just check their forums for all the unhappy users). Why do you need uTorrent running if it is only "idle"? Also, you seemed to have several windows/instances of Chrome running. If you are going for top speed, you should only open one website at a time. Even if you aren't doing anything on the others, they can be loading things in the background, such as ads and dynamic info. There are many factors contributing to your internet speed. And as part of how Chrome works, it tries to load parts of the web sites it thinks you will access next (part of its "perceived" speediness). Because of this, even when it is ACTUALLY done loading the page, it can appear to still be loading it. One more thing, and i'm sure you know this but, some information on websites comes from multiple sites, and so it must ping several locations and download data concurrently in some cases. This also includes many JavaScript files (which seemed to be some of the longer loads on your video). As somebody mentioned earlier, be sure you check your HOSTS file, as any excessive entries can slow DNS lookups down. It is a little bit of everything that affects speed...

  • I can confirm that it isn't related to uTorrent. Happens for me with qBittorrent or no torrent client at all. – user237698 Jan 25 '16 at 9:44

Things to try :

  1. In Command Prompt (cmd) enter ipconfig /flushdns
  2. Try adding to the chrome.exe call the parameter --enable-async-dns. To find out if Asynchronous DNS is enabled, access chrome://net-internals/#dns and verify that "Internal DNS client enabled" is set to "true" or "false".
  3. Delete temporary files
  4. Ensure that in Power Options the Power Plan is set to High performance
  5. Disable IPv6
  6. Ensure the computer is fully patched, especially in Windows Update, Optional section, for any hardware drivers

Reboot is required after most of the above when testing for improvement, except for point 2.

If none of the above helped, test if the slowdown occurs when booting in Safe mode.

You could also reset the TCP/IP stack by running these commands (Run as administrator) :

  • Reset WINSOCK entries to installation defaults: netsh winsock reset catalog
  • Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log
  • Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log
  • Reset the winsock catalog : netsh winsock reset catalog
  • Or just : netsh int ip reset reset.log
  • And netsh winsock reset catalog

There might be some duplication in the above commands, but this are all the reset commands that I know of.

If everything fails, the only advice I can think of is :

  • I started the bounty. I've tried all that stuff, none of it helps. – user237698 Jan 25 '16 at 8:33
  • Does this happen when booting in Safe mode? Or when using another browser than Chrome? – harrymc Jan 25 '16 at 11:17
  • Maybe a little better with Firefox, hard to say. Safe mode makes no difference. – user237698 Jan 25 '16 at 16:06
  • There are references in the answers to ping times, but no data. Have you tried to ping the DNS server(s) ? And will the ISP charge you if the problem is theirs? – harrymc Jan 25 '16 at 19:18
  • I tried a few different DNS servers. Generally ping times are in the 50-150ms range, it's just making actual DNS queries and then connecting to web sites that takes a long time. – user237698 Jan 26 '16 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.