1

Late 2012 Macbook Pro, 2.2ghz i5, 8gb ram, running OSX 10.9.3

My Novation Launchpad worked just fine 12 hours ago. I go to work, come home, plug in the device in question and I get this error:

"USB Devices Disabled: unplug the device using too much power to re-enable USB devices."

Things I tried (in order):

  • unplug device from USB hub (didn't work)
  • tried another cable (didn't work)
  • tried another port (didn't work)
  • plugged another USB device in (Novation LaunchControl) ...that works, weird...
  • plugged in Launchpad (didn't work)
  • restarted computer (didn't work)
  • shutdown completely, wait 1-3 minutes (didn't work)

I then did some research online and saw the same problem. So then I...

  • reset the PRAM/NVRAM at startup (didn't work)
  • reset SMC ...which to me doesn't seem any different than just shutting it off for a while
  • opened back cover...all seemed fine...nothing loose
  • install some more RAM that I just purchased (didn't work)

In "SYSTEM INFORMATION" under USB I see no sign of the USB device when I plug it in, nor do I hear any confirmation 'ding' to let me know it is being recognized.

Is there any way to reset all of my USB drivers?

tl;dr

I have one USB device that gives me the 'USB Device Disabled' because of low power error. All other USB devices I've tried work.

  • 1
    Is it possible that the USB device (that doesn't work) has developed a problem? It may have shorted the power and ground line (hence the not enough power error message). – LDC3 Jun 6 '14 at 5:15
  • i suppose that is the next logical thing to start troubleshooting. – MaylorTaylor Jun 6 '14 at 5:16
1
  1. Too many load-bearing devices
    This happens often when you plug something into a usb hub, which is already full of devices. A mac usb 2.0 port has a maximum load of 500mA or somewhere around there, and too many devices drawing a small amount of power can cause something to not work.

  2. Device draws too much current
    Having a device that tries to pull more than 500mA will cause this problem. One way to get around it is to have a powered hub, so that more current can be drawn without causing this problem

I recommend that you unplug everything and plug in your device on its own to see if that is the problem device. You can then start to plug more devices in until it cuts out, and figure your own way from there

protected by Community Apr 10 '15 at 11:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.