4

I know it is a pretty lame question, but I am not a pro in networking, so I will still ask it. And I will try to explain details where possible.

I want to create the following setup:

Phone line is in the hallway downstairs. I connect unit A to the phone line. Unit A is a combined ADSL modem + WiFi router + 4-port ethernet switch. (correct me if I am not using the terms correctly). The model is D-Link 3680.

Note: I know the modem functions correctly and connects to the Internet (I have tested it). I also know that DHCP in the router functions correctly and I can connect to the internet with my laptop.

I disable WiFi in unit A and run cable (in fact a PowerLine link) upstairs to the third floor.

Note: I have checked that I can connect to the internet on the the other side of the link. I still get address from DHCP of my router and everything is fine

What I want to do now, is instead of connecting to the cable on the third floor, hook up another router that I have. Unit B: Huawei HG533: a combined ADSL modem + WiFi router + 4-port ethernet switch with USB port for Storage Devices. I want to have wifi enabled on it and I want to connect to the internet through it. Obviously I disable modem functionality in this device and just connect the ethernet cable to the uplink.

The problem is, that I cannot connect to the internet once connected to the Unit B. And I cannot ping unit A.

So, could anyone sketch a correct network topology for this setup? What settings do I have to look at? Where do I even start. Which one of two units (or both) need(s) to run DHCP server? Do they have to be on the same subnet? How do I setup default gateways.

   [Internet]
       |
  [Phone Line]
       |
       |
|--------------|                 |---------------|                                        
|   Unit A     |                 |   Unit B      |          |---------------|
|  ADSL modem  |---[powerline]---| ADSL disabled |--[WiFi]--|   Laptop(s)   |
|              |                 |       DHCP?   |          |---------------|
|--------------|                 |---------------|
                                         |
                                         |
                                       [USB]
                                         |
                                 |---------------|
                                 |      HDD      |
                                 |---------------|

Oh, and if anyone is interested in why am i doing it. It is simple: Reason 1: I don't want to have my WiFi Router downstairs because signal is weak on the third floor. Reason 2: I use USB port and connect my 1Tb hdd to it and I don't want to leave it in the hallway, because I live in the flatshare with people I don't really know. Reason 3: I want to have WiFi within my room, not just an ethernet cable.

Sorry for being such a n00b, any advice will be appreciated. Oh, and I have read this thread, but does not provide enough explanation.

UPDATE: in response to CharlieRB's comment, here is a picture of the Unit B:

enter image description here

  • 1
    When you say "connect the ethernet cable to the uplink", is there a port actually called uplink? Or are you referring to the ADSL port? Or is it the WAN port? – CharlieRB Jun 6 '14 at 13:14
  • There is one marked as "fiber". I believe it to be the uplink. It is a standard RJ45 though. I will upload the picture to my original post. – Art Gertner Jun 6 '14 at 13:53
  • 1
    I'm unsure if this is off topic here and should be sent to Server fault. – Max Ried Jun 7 '14 at 11:20
  • 1
    I had a look at your Huawei. Its manual is really economical... You want to try: 1) Disable the DHCP server on the Huawei. 2) Set it to bridge mode and make itself get its IP using DHCP from the D-Link Router or set manually to one in the D-Link's subnet. 3) DO NOT use the Fibre port. Connect the PowerLine adapter to one of the yellow sockets. – Max Ried Jun 7 '14 at 12:19
  • 1
    I agree with @MaxRied. I have a similar setup in my house (but I run two wifi networks, one upstairs and one downstairs). In my setup, I have a combined ADSL modem and router connected to the phoneline downstairs running a DHCP server. I have connected an Ethernet cable from a LAN socket on this router to a LAN socket (not WAN) on a router upstairs with the DHCP server disabled which broadcasts a separate wireless network. The upstairs router behaves as a switch and IP addresses are distributed to devices connecting to the upstairs wifi by the DHCP server on the downstairs router. – James Womack Jun 11 '14 at 8:59
0

Ok, so I am finally answering my own question here. The answer is derived from the comments by Max Ried and James Womack. I wouldn't have figured it out on my own. In fact, my original setup was 100% correct. The problem was that Unit B (Huawei HG533) has a bug that does not allow clients connected to it to use external DHCP server. The only change I made was setting static IPs and now everything works.

So what I did was:

  • I set address of Unit A (D-Link modem + router) to 192.168.1.2 and connected it to the phoneline.

  • I have connected powerline adapter to one of the LAN ports of Unit A and plugged it into the mains

  • On the top floor of the apartment I have plugged another powerline adapter into the mains and connected it to one of the LAN ports of Unit B. I have figured out that it does not make any difference if I connect it to one of LAN ports or to the one labeled as "Fiber" - result is the same

  • I have disabled WiFi in unit A and enabled WiFi in unit B

  • I now connect to unit B and I have access to NAS, connected to unit B and to the internet available through Unit A.

However: I did not manage to setup DHCP. This seems to be the problem that initially did not allow me to create desired setup. I am currently using static IP address for both Unit A, Unit B and all clients connected to Unit B.

There is a setting called "DHCP transparent transparrent transmission" and another one called "DHCP relay" - both have no effect. I have tried enabling DHCP for Unit A and dissabling it for Unit B and putting it into Bridge mode with Transparent DHCP transmission no effect.

Quick search on the internet showed that this is a feature of Huawei HG533 and it seems like no one can get it to transmit DHCP transparently from LAN.

[Link 1]

[Link 2]

Anyway, I am happy with my current setup even though it is static IP. I am planning to replace unit B (Huawei HG533) with Asus RT-N16 running openWrt soon anyway.

Thanks to everyone who helped me to sort this out.

UPDATE: here are screenshots from the interface of Unit B (Huawei) enter image description here

enter image description here

  • That's protection from rogue DHCP-Servers. – Max Ried Jun 24 '14 at 19:15
  • @MaxRied Could you elaborate on rogue DHCP-Server protection, plz? What does it have to do with having a couple of tick boxes that don't work? I am interested – Art Gertner Jun 24 '14 at 19:18
  • Didn't tell you it's functioning correctly. Just saying not forwarding DHCP through a gateway is often desired behavior. – Max Ried Jun 24 '14 at 19:20
  • Oh, ok. I get it now – Art Gertner Jun 24 '14 at 19:22
  • Having multiple DHCPs in one routing domain WILL bring you in severe trouble. You won't configure your network with more than one DHCP-server, except you REALLY know what you are doing. Or by accident. And that's what this setting is protecting you from. – Max Ried Jun 24 '14 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.